summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSTommydx2019-02-17 02:54:56 +0800
committerSTommydx2019-02-17 02:54:56 +0800
commitba4e62db8b76cb40204bd3b864fa13b66cbbd15d (patch)
tree82898ab41d86baa944043b6209a687e716673231
downloadaur-ba4e62db8b76cb40204bd3b864fa13b66cbbd15d.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0db58f8c661b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-certipy
+ pkgdesc = A simple python tool for creating certificate authorities and certificates on the fly
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/LLNL/certipy
+ arch = any
+ license = BSD
+ makedepends = python-pypandoc
+ depends = python
+ depends = python-pyopenssl
+ source = https://files.pythonhosted.org/packages/source/c/certipy/certipy-0.1.2.tar.gz
+ sha256sums = 3461c5ff28eda977185132d4c6d4393989c7dd996ba8c780b07b9b4e679d455a
+
+pkgname = python-certipy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c44e935977a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tommy Li <ttoo74@gmail.com>
+pkgname=python-certipy
+_name=${pkgname#python-}
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A simple python tool for creating certificate authorities and certificates on the fly"
+arch=(any)
+url="https://github.com/LLNL/certipy"
+license=('BSD')
+depends=("python" "python-pyopenssl")
+makedepends=("python-pypandoc")
+checkdepends=()
+optdepends=()
+options=()
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('3461c5ff28eda977185132d4c6d4393989c7dd996ba8c780b07b9b4e679d455a')
+
+prepare() {
+ # fix permission error
+ chmod -R u+rwX,go+rX,go-w "$_name-$pkgver"
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+