summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-07-19 17:36:35 -0400
committerGuillaume Horel2021-07-19 17:36:35 -0400
commite9cc5c39f156fcdbb388931d175cca6d1bd97b3a (patch)
treeb08ec6a05583c2a34241949a03c99fe25d0bec94
parent9d09ebd6639ab86e3aaec97a47c42d9da2de1737 (diff)
downloadaur-e9cc5c39f156fcdbb388931d175cca6d1bd97b3a.tar.gz
fix setup.py
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
-rw-r--r--install.patch15
3 files changed, 26 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3885ce014f3..cf2e9e48a8bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,8 @@ pkgbase = python-cffsubr
makedepends = python-setuptools
depends = python-fonttools
source = https://files.pythonhosted.org/packages/source/c/cffsubr/cffsubr-0.2.8.tar.gz
+ source = install.patch
sha256sums = e24bd03c94944e1536ec8437ab83fb4ac38477412426c1ffd4e056dd16cde235
+ sha256sums = fcbb43d2f977e6aca13c4d2ec4e8012417996339b4d7f6b2bf0cedb90ebed9c5
pkgname = python-cffsubr
-
diff --git a/PKGBUILD b/PKGBUILD
index 4f7a0f4279ad..ff0cc06139d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,15 @@ makedepends=('python-setuptools')
optdepends=()
license=('Apache')
arch=('x86_64')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('e24bd03c94944e1536ec8437ab83fb4ac38477412426c1ffd4e056dd16cde235')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+ "install.patch")
+sha256sums=('e24bd03c94944e1536ec8437ab83fb4ac38477412426c1ffd4e056dd16cde235'
+ 'fcbb43d2f977e6aca13c4d2ec4e8012417996339b4d7f6b2bf0cedb90ebed9c5')
+
+prepare() {
+ cd "${_pkgname}-${pkgver}"
+ patch -p1 < ../install.patch
+}
package() {
cd "${_pkgname}-${pkgver}"
diff --git a/install.patch b/install.patch
new file mode 100644
index 000000000000..33e6f6d37603
--- /dev/null
+++ b/install.patch
@@ -0,0 +1,15 @@
+diff -urN cffsubr-0.2.8-orig/setup.py cffsubr-0.2.8/setup.py
+--- cffsubr-0.2.8-orig/setup.py 2021-07-19 12:16:53.924141568 -0400
++++ cffsubr-0.2.8/setup.py 2021-07-19 12:17:12.630869015 -0400
+@@ -142,11 +142,6 @@
+ "importlib_resources; python_version < '3.7'",
+ "fontTools >= 4.10.2",
+ ],
+- setup_requires=[
+- "setuptools_scm",
+- # finds all git tracked files including submodules when making sdist MANIFEST
+- "setuptools-git-ls-files",
+- ],
+ extras_require={"testing": ["pytest"]},
+ python_requires=">=3.6",
+ classifiers=[