summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin2015-06-16 21:29:09 +0800
committerLin2015-06-16 21:29:09 +0800
commit80ef07851ef33be57b9c69e55516fa073fb15e97 (patch)
treed0eb3b86f4d9e6b1b271d5139041dfb2eeb53281
downloadaur-80ef07851ef33be57b9c69e55516fa073fb15e97.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78c09716a4ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-charade
+ pkgdesc = Universal encoding detector for Python 2 and 3. Python3 version.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/sigmavirus24/charade
+ arch = any
+ license = LGPL
+ depends = python
+ source = http://pypi.python.org/packages/source/c/charade/charade-1.0.3.tar.gz
+ md5sums = 79ac701a147705c09bdce31b79dfa12e
+
+pkgname = python-charade
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bdc22125501
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Cravix <dr dot neemous at gmail dot com>
+# Contributor: Veli-Jussi Raitila <vjr AT iki DOT fi>
+
+pkgname=python-charade
+_pkgname=charade
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Universal encoding detector for Python 2 and 3. Python3 version."
+arch=('any')
+url="https://github.com/sigmavirus24/charade"
+license=('LGPL')
+depends=('python')
+
+source=(http://pypi.python.org/packages/source/c/charade/${_pkgname}-${pkgver}.tar.gz)
+md5sums=('79ac701a147705c09bdce31b79dfa12e')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ python3 setup.py install --root="$pkgdir" || return 1
+}