summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Brinister2023-07-05 08:22:35 -0400
committerAlex Brinister2023-07-05 09:00:18 -0400
commit06aaf28b8f90d52a4e8c17b5442a23b24c2e0b05 (patch)
tree74d9d72c8bc769aa92d0b0d55cce3741b229a321
parenteee5e4f41daa561b8afba4fbea00eaf1f64d059f (diff)
downloadaur-06aaf28b8f90d52a4e8c17b5442a23b24c2e0b05.tar.gz
updated to mirror non-vcs pkgbuild
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD88
-rw-r--r--cheetah.1138
3 files changed, 217 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb553e371c06..25021b35f950 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,31 @@
pkgbase = python-cheetah3-git
pkgdesc = A Python powered template engine and code generator
- pkgver = 3.2.6.post1.r9.g856329c
+ pkgver = 3.3.1.r4.g4948522
pkgrel = 1
- url = http://www.cheetahtemplate.org
- arch = any
+ url = https://cheetahtemplate.org
+ arch = x86_64
license = MIT
+ license = custom:Public
+ checkdepends = python-markdown
+ checkdepends = python-pygments
makedepends = git
+ makedepends = python
makedepends = python-setuptools
- makedepends = python2-setuptools
+ makedepends = python-sphinx
+ optdepends = python-markdown: for markdown filter
+ optdepends = python-pygments: for codehighlight filter
conflicts = python-cheetah3
- source = cheetah3::git+https://github.com/CheetahTemplate3/cheetah3.git
- sha512sums = SKIP
+ source = python-cheetah3-git::git+https://github.com/CheetahTemplate3/cheetah3.git
+ source = cheetah.1
+ b2sums = SKIP
+ b2sums = 59c0689df18640aea8e671cd267741d1bff4b3954147a34ac71c67ec8399c08460976ecabdce7c7b866bd895c8963b6f03059e496eb7dfa2710d99deba78503d
pkgname = python-cheetah3-git
depends = python
- optdepends = python-markdown
+ optdepends = python-markdown: for markdown filter
+ optdepends = python-memcache: for caching
+ optdepends = python-pygments: for code highlight filter
+ optdepends = python-cheetah3-docs: documentation
-pkgname = python2-cheetah3-git
- depends = python2
- optdepends = python2-markdown
+pkgname = python-cheetah3-docs-git
+ pkgdesc = A Python powered template engine and code generator (documentation)
diff --git a/PKGBUILD b/PKGBUILD
index ab9f1a10fdf8..26885e046de3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,79 @@
# Maintainer: Alex Brinister <alex_brinister at yahoo dot com>
pkgbase=python-cheetah3-git
-pkgname=('python-cheetah3-git' 'python2-cheetah3-git')
-_name=Cheetah3
-_reponame=cheetah3
-pkgver=3.2.6.post1.r9.g856329c
+_pkgbase=${pkgbase%-git}
+pkgname=('python-cheetah3-git' 'python-cheetah3-docs-git')
+pkgver=3.3.1.r4.g4948522
pkgrel=1
-pkgdesc="A Python 3-powered template engine and code generator"
-arch=('any')
-url="http://www.cheetahtemplate.org"
-license=(MIT)
-conflicts=('python-cheetah3')
-pkgrel=1
-pkgdesc="A Python powered template engine and code generator"
-makedepends=('git'
- 'python-setuptools'
- 'python2-setuptools')
-source=("${_reponame}::git+https://github.com/CheetahTemplate3/${_reponame}.git")
-sha512sums=('SKIP')
+pkgdesc='A Python powered template engine and code generator'
+arch=('x86_64')
+url="https://cheetahtemplate.org"
+license=('MIT' 'custom:Public') # manpage released by Debian in public domain
+makedepends=('git' 'python' 'python-setuptools' 'python-sphinx')
+checkdepends=('python-markdown' 'python-pygments')
+optdepends=(
+ 'python-markdown: for markdown filter'
+ 'python-pygments: for codehighlight filter'
+)
+conflicts=("${_pkgbase}")
+source=(
+ "${pkgbase}::git+https://github.com/CheetahTemplate3/${_pkgbase##python-}.git"
+ 'cheetah.1'
+)
+b2sums=('SKIP'
+ '59c0689df18640aea8e671cd267741d1bff4b3954147a34ac71c67ec8399c08460976ecabdce7c7b866bd895c8963b6f03059e496eb7dfa2710d99deba78503d')
pkgver() {
- cd "${srcdir}/${_reponame}"
+ cd "${pkgbase}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "${pkgbase}"
+ python setup.py build
+
+ # generate documentation
+ PYTHONPATH="$PWD:$PYTHONPATH" make -C docs html
+}
+
+check() {
+ cd "${pkgbase}"
+
+ export PYTHONPATH="$PWD:$PYTHONPATH"
+ export PATH="$PWD/bin:$PATH"
+ python Cheetah/Tests/Test.py
+}
package_python-cheetah3-git() {
depends=('python')
- optdepends=('python-markdown')
+ optdepends=(
+ 'python-markdown: for markdown filter'
+ 'python-memcache: for caching'
+ 'python-pygments: for code highlight filter'
+ 'python-cheetah3-docs: documentation'
+ )
- cd "${srcdir}/${_reponame}"
+ cd "${pkgbase}"
python setup.py install --root="${pkgdir}" --optimize=1
+
+ # man pages
+ install -vDm644 -t "${pkgdir}/usr/share/man/man1" "${srcdir}/cheetah.1"
+ ln -sf cheetah.1.gz "${pkgdir}/usr/share/man/man1/cheetah-compile.1.gz"
+ ln -sf cheetah.1.gz "${pkgdir}/usr/share/man/man1/cheetah-analyze.1.gz"
+
+ # license
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package_python2-cheetah3-git() {
- depends=('python2')
- optdepends=('python2-markdown')
+package_python-cheetah3-docs-git() {
+ pkgdesc+=' (documentation)'
- cd "${srcdir}/${_reponame}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgbase}"
+
+ # documentation
+ install -vDm644 -t "${pkgdir}/usr/share/doc/${pkgbase}" README.rst
+ cp -vr docs/_build/html "${pkgdir}/usr/share/doc/${pkgbase}"
- # Avoid conflict with python-cheetah3
- for name in cheetah cheetah-analyze cheetah-compile; do
- mv "${pkgdir}/usr/bin/${name}"{,2}
- done
+ # license
+ install -vDm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}
diff --git a/cheetah.1 b/cheetah.1
new file mode 100644
index 000000000000..9e04760a561c
--- /dev/null
+++ b/cheetah.1
@@ -0,0 +1,138 @@
+.\" Hey, EMACS: -*- nroff -*-
+.\" First parameter, NAME, should be all caps
+.\" Second parameter, SECTION, should be 1-8, maybe w/ subsection
+.\" other parameters are allowed: see man(7), man(1)
+.TH CHEETAH 1 "2005 Apr 04"
+.\" Please adjust this date whenever revising the manpage.
+.\"
+.\" Some roff macros, for reference:
+.\" .nh disable hyphenation
+.\" .hy enable hyphenation
+.\" .ad l left justify
+.\" .ad b justify to both left and right margins
+.\" .nf disable filling
+.\" .fi enable filling
+.\" .br insert line break
+.\" .sp <n> insert n+1 empty lines
+.\" for manpage-specific macros, see man(7)
+.SH NAME
+cheetah \- Python template command-line tool
+.SH SYNOPSIS
+.B cheetah, cheetah-compile
+.PP
+.B cheetah COMMAND
+.RI [ options ] " FILE" ...
+.br
+.B cheetah-compile
+.RI [ options ] " FILE" ...
+.SH DESCRIPTION
+This manual page documents briefly the
+\fBcheetah\fP command-line tool. This manual page was written for the Debian
+distribution because the original program does not have a manual page.
+.PP
+.\" TeX users may be more comfortable with the \fB<whatever>\fP and
+.\" \fI<whatever>\fP escape sequences to invode bold face and italics,
+.\" respectively.
+\fBcheetah\fP is a Python-powered template engine and code generator. It can be
+used as a standalone utility or it can be combined with other tools. Cheetah
+has many potential uses, but web developers looking for a viable alternative to
+ASP, JSP, PHP and PSP are expected to be its principle user group.
+.PP
+The \fBcheetah\fP command-line tool is the standalone utility portion of the
+software suite. \fBcheetah-compile\fP is a convenience script that for the
+"\fBcheetah compile ...\fP" command. The utility accepts a single command
+possible options and a list of files. If \fBFILE\fP is a single "-", read
+standard input and write standard output.
+.SH COMMANDS
+.\" cheetah compile [options] [FILES ...] : Compile template definitions
+.\" cheetah fill [options] [FILES ...] : Fill template definitions
+.\" cheetah help : Print this help message
+.\" cheetah options : Print options help message
+.\" cheetah test : Run Cheetah's regression tests
+.\" cheetah version : Print Cheetah version number
+The possible \fBcheetah\fP commands are listed below. You may abbreviate the
+command to the first letter; e.g., 'h' == 'help'.
+.TP
+.B compile
+Compile template definitions
+.TP
+.B fill
+Fill template definitions
+.TP
+.B help
+Print commands help message
+.TP
+.B options
+Print options help message for compile and fill commands
+.TP
+.B test
+Run regression tests
+.TP
+.B version
+Print version number
+.\".B
+.SH OPTIONS
+.\" --idir DIR, --odir DIR : input/output directories (default: current dir)
+.\" --iext EXT, --oext EXT : input/output filename extensions
+.\" (default for compile: tmpl/py, fill: tmpl/html)
+.\" -R : recurse subdirectories looking for input files
+.\" --debug : print lots of diagnostic output to standard error
+.\" --env : put the environment in the searchList
+.\" --flat : no destination subdirectories
+.\" --nobackup : don't make backups
+.\" --pickle FILE : unpickle FILE and put that object in the searchList
+.\" --stdout, -p : output to standard output (pipe)
+The options for
+.B cheetah
+apply to the
+.B compile
+and
+.B fill
+commands. A summary of options is included below.
+.TP
+.B \-\-idir DIR
+Input directories(default: current dir)
+.TP
+.B \-\-odir ODIR
+Output directories (default: current dir)
+.TP
+.B \-\-iext IEXT
+Input extension. The default input extension for both the
+\fBcompile\fP and \fBfill\fP commands is "\fBtmpl\fP".
+.TP
+.B \-\-oext OEXT
+Output extension. The default output extension for the
+\fBcompile\fP command is "\fBpy\fP". The default output extension for \fBfill\fP
+is "\fBhtml\fB".
+.TP
+.B \-R
+Recurse subdirectories looking for input files
+.TP
+.B \-\-debug
+Print lots of diagnostic output to the standard error file descriptor
+.TP
+.B \-\-env
+Print the environment in the searchList
+.TP
+.B \-\-flat
+No destination subdirectories
+.TP
+.B \-\-nobackup
+Do not make backups
+.TP
+.B \-\-pickle FILE
+unpickle FILE and put that output in the searchList
+.TP
+.B \-\-stdout, \-p
+Output to standard output file descriptor (pipe)
+.SH SEE ALSO
+.BR pydoc(1)
+.br
+The programs are documented fully on the project website
+.IR http://cheetahtemplate.sourceforge.net.
+You can also browse the Python library files and their docstring descriptions
+by using the standard pydoc utility.
+.SH AUTHOR
+This manual page was written by Chad C. Walstrom <chewie@debian.org>,
+for the Debian project and is dedicated to the Public Domain.
+