summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2015-08-07 11:42:20 -0400
committerEric Berquist2015-08-07 11:42:20 -0400
commitc88b86a620b9f659cd39d2426ae0a72050e9ad59 (patch)
treed0e8c920214d19495f8728f213c4a183477173b8
downloadaur-c88b86a620b9f659cd39d2426ae0a72050e9ad59.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4839a9d66df6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = python-chemview-git
+ pkgdesc = An interactive molecular viewer for the IPython notebook (git version)
+ pkgver = 0.3.r87.c7e9150
+ pkgrel = 1
+ url = http://chemview.readthedocs.org/en/latest
+ arch = any
+ license = LGPL2.1
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = python-numba
+ depends = ipython-notebook
+ depends = python2
+ depends = python2-numpy
+ depends = python2-numba
+ depends = ipython2-notebook
+ source = git+https://github.com/gabrielelanaro/chemview
+ sha256sums = SKIP
+
+pkgname = python-chemview-git
+ provides = python-chemview
+ conflicts = python-chemview
+
+pkgname = python2-chemview-git
+ provides = python2-chemview
+ conflicts = python2-chemview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20b9f2a7855b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+
+_name="chemview"
+pkgbase="python-${_name}-git"
+pkgname=("python-${_name}-git" "python2-${_name}-git")
+pkgver=0.3.r87.c7e9150
+pkgrel=1
+pkgdesc="An interactive molecular viewer for the IPython notebook (git version)"
+arch=("any")
+url="http://chemview.readthedocs.org/en/latest"
+license=("LGPL2.1")
+depends=("python" "python-numpy" "python-numba" "ipython-notebook"
+ "python2" "python2-numpy" "python2-numba" "ipython2-notebook")
+makedepends=("git")
+source=("git+https://github.com/gabrielelanaro/${_name}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ _parent_ver=$(git log --tags --simplify-by-decoration --pretty="format:%d" | head -n 1 | cut -d " " -f 6 | tr -d "v,")
+ printf "%s.r%s.%s" \
+ "${_parent_ver}" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+build_python-chemview-git() {
+ cd "${srcdir}/${_name}"
+ python setup.py build
+}
+
+build_python2-chemview-git() {
+ cd "${srcdir}/${_name}"
+ python2 setup.py build
+}
+
+package_python-chemview-git() {
+ provides=("python-${_name}")
+ conflicts=("python-${_name}")
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+package_python2-chemview-git() {
+ provides=("python2-${_name}")
+ conflicts=("python2-${_name}")
+ cd "${srcdir}/${_name}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}