summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Javorski2020-06-10 22:38:58 -0700
committerMike Javorski2020-06-10 22:38:58 -0700
commit0655f3907c092fb6e6c8291a42b0d6738fc2ec9a (patch)
tree5af65956c7f74d946e671dc8910e99ad9af6d9a0
downloadaur-0655f3907c092fb6e6c8291a42b0d6738fc2ec9a.tar.gz
Initial packaging for v0.13.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba0dbdcb1814
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-chevron
+ pkgdesc = A python implementation of the mustache templating language.
+ pkgver = 0.13.1
+ pkgrel = 1
+ url = https://github.com/noahmorrison/chevron
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = chevron
+ conflicts = chevron
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/c/chevron/chevron-0.13.1.tar.gz
+ sha256sums = f95054a8b303268ebf3efd6bdfc8c1b428d3fc92327913b4e236d062ec61c989
+
+pkgname = python-chevron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd6cbc8b1e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mike Javorski (javmorin) <mike.javorski gmail com>
+pkgname=python-chevron
+_name=${pkgname#python-}
+pkgver=0.13.1
+pkgrel=1
+pkgdesc='A python implementation of the mustache templating language.'
+arch=('any')
+url="https://github.com/noahmorrison/chevron"
+license=('MIT')
+provides=('chevron')
+conflicts=('chevron')
+depends=('python')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('f95054a8b303268ebf3efd6bdfc8c1b428d3fc92327913b4e236d062ec61c989')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+
+ /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+}