summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Timms2020-06-04 10:27:05 -0400
committerLiam Timms2020-06-04 10:27:05 -0400
commit6793cc7bdf75e2910ac225b0f3ae52ae233ca6c6 (patch)
tree44139b4e7407e52c0884c0639b0acc5e0c8d164d
downloadaur-6793cc7bdf75e2910ac225b0f3ae52ae233ca6c6.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81973615d0c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-ci-info
+ pkgdesc = A Python implementation of watson/ci-info. Data on Continuous Integration environment.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/mgxd/ci-info
+ arch = any
+ license = MIT
+ depends = python-pytest
+ source = ci-info-0.2.0.tar.gz::https://github.com/mgxd/ci-info/archive/0.2.0.tar.gz
+ md5sums = 6c0f263aaff41772d3fe8c4236c3dd91
+
+pkgname = python-ci-info
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef8f26d3e196
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Liam Timms <timms5000@gmail.com>
+pkgname=python-ci-info
+_name=${pkgname#python-}
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A Python implementation of watson/ci-info. Data on Continuous Integration environment."
+arch=('any')
+url='https://github.com/mgxd/ci-info'
+license=('MIT')
+depends=('python-pytest')
+makedepends=()
+optdepends=()
+source=("${_name}-${pkgver}.tar.gz::https://github.com/mgxd/${_name}/archive/${pkgver}.tar.gz")
+md5sums=('6c0f263aaff41772d3fe8c4236c3dd91')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+