summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-30 03:57:09 +0800
committerUniversebenzene2019-08-30 03:57:09 +0800
commit09c87e049dfad78314db0b4fddeddffe9f864b60 (patch)
tree415c49862545da2c550f3346490542a569ade6b8
downloadaur-09c87e049dfad78314db0b4fddeddffe9f864b60.tar.gz
Initial import 0.4
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD39
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72cb78a0a437
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-ci_watson
+ pkgdesc = CI helper for STScI Jenkins
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://ci_watson.readthedocs.io
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python-relic
+ makedepends = python-pytest
+ makedepends = python-sphinx_rtd_theme
+ makedepends = python-numpydoc
+ makedepends = python-sphinx-automodapi
+ source = https://github.com/spacetelescope/ci_watson/archive/0.4.tar.gz
+ md5sums = 64a92637b9ff11a5b126e2cc6e5d17e7
+
+pkgname = python-ci_watson
+ depends = python>=3.5
+ depends = python-pytest>=3
+ optdepends = python-ci_watson-doc: Documentation for CI Watson
+
+pkgname = python-ci_watson-doc
+ pkgdesc = Documentation for CI Watson
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef6375f75615
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+LICENSE*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ae0f5b9ef80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+pkgbase=python-ci_watson
+_pyname=${pkgbase#python-}
+pkgname=("python-${_pyname}" "python-${_pyname}-doc")
+pkgver=0.4
+pkgrel=1
+pkgdesc="CI helper for STScI Jenkins"
+arch=('i686' 'x86_64')
+url="https://ci_watson.readthedocs.io"
+license=('BSD')
+makedepends=('python-setuptools' 'python-relic' 'python-pytest' 'python-sphinx_rtd_theme' 'python-numpydoc' 'python-sphinx-automodapi')
+source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz")
+md5sums=('64a92637b9ff11a5b126e2cc6e5d17e7')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+ python setup.py build
+
+ msg "Building Docs"
+ python setup.py build_sphinx
+}
+
+package_python-ci_watson() {
+ depends=('python>=3.5' 'python-pytest>=3')
+ optdepends=('python-ci_watson-doc: Documentation for CI Watson')
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.md
+ install -D -m644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+package_python-ci_watson-doc() {
+ pkgdesc="Documentation for CI Watson"
+ cd ${srcdir}/${_pyname}-${pkgver}/build/sphinx
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
+}