summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Nagy2022-08-09 21:07:02 +0000
committerRoland Nagy2022-08-09 21:07:02 +0000
commit50985a965ccbc5fe3e0136230e28497b267611e4 (patch)
tree7b0163a80465455c43b3a4b38955b243299f091a
parent80ca32ca8069db445e66714b409d0c84603fe53d (diff)
downloadaur-50985a965ccbc5fe3e0136230e28497b267611e4.tar.gz
upgrade package to version 0.3.35
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07f1d70046d1..8dce83499f9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-cipheydists
pkgdesc = A collection of sample distributions for use in Ciphey's frequency analysis
- pkgver = 0.3.22
+ pkgver = 0.3.35
pkgrel = 1
url = https://github.com/Ciphey/CipheyDists
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-cipheydists
makedepends = python-setuptools
makedepends = python-poetry
depends = python
- source = python-cipheydists-0.3.22.tar.gz::https://github.com/Ciphey/CipheyDists/archive/refs/tags/v0.3.22.tar.gz
- sha256sums = 3a433013e7c34c9525dd66a8e6182391d4e5cfcdb5c236792d1ffd883c0d49d1
+ source = python-cipheydists-0.3.35.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-0.3.35.tar.gz
+ sha256sums = 3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88
pkgname = python-cipheydists
diff --git a/PKGBUILD b/PKGBUILD
index e2565756b140..c2a330c9859a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Hao Long <aur@esd.cc>
pkgname=python-cipheydists
-pkgver=0.3.22
+pkgver=0.3.35
pkgrel=1
pkgdesc="A collection of sample distributions for use in Ciphey's frequency analysis"
arch=("any")
@@ -13,11 +13,11 @@ makedepends=(
"python-setuptools"
"python-poetry"
)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=("3a433013e7c34c9525dd66a8e6182391d4e5cfcdb5c236792d1ffd883c0d49d1")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-$pkgver.tar.gz")
+sha256sums=("3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88")
build() {
- cd "$srcdir/CipheyDists-$pkgver"
+ cd "$srcdir/cipheydists-$pkgver"
poetry build
cd dist
@@ -27,7 +27,7 @@ build() {
}
package() {
- cd "$srcdir/CipheyDists-$pkgver/dist/cipheydists-$pkgver"
+ cd "$srcdir/cipheydists-$pkgver/dist/cipheydists-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 "$srcdir/CipheyDists-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/cipheydists-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}