summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpusi772023-05-07 15:47:09 +0200
committerpusi772023-05-07 15:47:09 +0200
commitc6c456dd2f9d05eba51eb7973f16ca8ef1b2500e (patch)
treee4c81f07cd1e4e75513923748677b186b1df55b3
parent50985a965ccbc5fe3e0136230e28497b267611e4 (diff)
downloadaur-c6c456dd2f9d05eba51eb7973f16ca8ef1b2500e.tar.gz
adopted and fixed broken package
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD25
3 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dce83499f9d..0b0e1d25049c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-cipheydists
pkgdesc = A collection of sample distributions for use in Ciphey's frequency analysis
pkgver = 0.3.35
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Ciphey/CipheyDists
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-poetry
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
source = python-cipheydists-0.3.35.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-0.3.35.tar.gz
sha256sums = 3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dccc7769c72
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index c2a330c9859a..20c6aec66643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
-# Maintainer: Roland Nagy <roliboy@protonmail.com>
-# Contributor: Hao Long <aur@esd.cc>
+# Maintainer: pusi77 <pusineriandrea+gmail+com>
pkgname=python-cipheydists
pkgver=0.3.35
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of sample distributions for use in Ciphey's frequency analysis"
arch=("any")
url="https://github.com/Ciphey/CipheyDists"
-license=("MIT")
+license=("The Unlicense")
depends=("python")
makedepends=(
+ "python-build"
+ "python-installer"
+ "python-wheel"
"python-setuptools"
- "python-poetry"
)
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-$pkgver.tar.gz")
-sha256sums=("3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88")
+sha256sums=('3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88')
build() {
cd "$srcdir/cipheydists-$pkgver"
- poetry build
-
- cd dist
- tar xf "cipheydists-$pkgver.tar.gz"
- cd "cipheydists-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/cipheydists-$pkgver/dist/cipheydists-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 "$srcdir/cipheydists-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "cipheydists-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}