summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Ortiz2023-10-02 13:44:12 -0500
committerFernando Ortiz2023-10-02 13:44:12 -0500
commit7f3232a6d1026b528199a5c557e60133271eee86 (patch)
tree940d3aeaa0b98ec04b62286b6d4641dec8233aa4
parent61a68851f83cf845e002b193504ab8b209309c92 (diff)
downloadaur-7f3232a6d1026b528199a5c557e60133271eee86.tar.gz
update package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rwxr-xr-xpkgsum.sh7
-rwxr-xr-xupdate.sh5
4 files changed, 17 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baf60dd004b3..7f455e10918c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-ck
pkgdesc = Collective Knowledge - lightweight knowledge manager to organize, cross-link, share and reuse artifacts and workflows
- pkgver = 1.12.3
- pkgrel = 5
+ pkgver = 2.6.3
+ pkgrel = 1
url = https://github.com/ctuning/ck
arch = any
license = BSD 3-clause
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/c/ck/ck-1.12.3.tar.gz
- sha256sums = 77f7278f44521e976feb09de115d6823a9f503d82d3fd1882b836f77860fbc70
+ source = https://files.pythonhosted.org/packages/source/c/ck/ck-2.6.3.tar.gz
+ sha256sums = 227737f4b99af2f18d54560caa1099106fe1d7290ded2c969a0fe6c746ef9ce8
pkgname = python-ck
pkgdesc = Collective Knowledge - lightweight knowledge manager to organize, cross-link, share and reuse artifacts and workflows for Python 3
@@ -16,11 +15,3 @@ pkgname = python-ck
depends = ipython
depends = python
depends = python-pip
-
-pkgname = python2-ck
- pkgdesc = Collective Knowledge - lightweight knowledge manager to organize, cross-link, share and reuse artifacts and workflows for Python 2
- depends = git
- depends = ipython2
- depends = python2
- depends = python2-pip
-
diff --git a/PKGBUILD b/PKGBUILD
index 482f7158cebc..bf098bac1a79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,28 @@
# Maintainer: Fernando Ortiz <nandub+arch@nandub.info>
pkgbase=python-ck
-pkgname=('python-ck' 'python2-ck')
+pkgname=('python-ck')
_name=ck
-pkgver=1.12.3
-pkgrel=5
+pkgver=2.6.3
+pkgrel=1
pkgdesc='Collective Knowledge - lightweight knowledge manager to organize, cross-link, share and reuse artifacts and workflows'
arch=('any')
url='https://github.com/ctuning/ck'
license=('BSD 3-clause')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
source=(https://files.pythonhosted.org/packages/source/c/ck/${_name}-${pkgver}.tar.gz)
-sha256sums=('77f7278f44521e976feb09de115d6823a9f503d82d3fd1882b836f77860fbc70')
-
-prepare() {
- # copy folder, so we can cleanly build for both python versions
- cp -rup ck-$pkgver py2ck-$pkgver
-}
+sha256sums=('227737f4b99af2f18d54560caa1099106fe1d7290ded2c969a0fe6c746ef9ce8')
build() {
# build for python 3
cd ck-$pkgver
python setup.py build
-
- # build for python 2
- cd ../py2ck-$pkgver
- python2 setup.py build
}
package_python-ck() {
- depends=('git' 'ipython' 'python' 'python-pip')
+ depends=('git' 'ipython' 'python' 'python-pip')
pkgdesc+=' for Python 3'
cd ck-$pkgver
- python setup.py install --root=${pkgdir}/ --optimize=1
-}
-
-package_python2-ck() {
- depends=('git' 'ipython2' 'python2' 'python2-pip')
- pkgdesc+=' for Python 2'
-
- cd py2ck-$pkgver
- python2 setup.py install --root=${pkgdir}/ --optimize=1
+ python setup.py install --root=${pkgdir}/ --optimize=1
}
diff --git a/pkgsum.sh b/pkgsum.sh
index e908ad353016..6a1258f57f9d 100755
--- a/pkgsum.sh
+++ b/pkgsum.sh
@@ -12,4 +12,9 @@ BEGIN {
}
1
-' PKGBUILD > PKGBUILD.new && mv PKGBUILD{.new,} \ No newline at end of file
+' PKGBUILD > PKGBUILD.new && mv PKGBUILD{.new,}
+if which makepkg &> /dev/null; then
+ makepkg --printsrcinfo > .SRCINFO
+else
+ mksrcinfo
+fi
diff --git a/update.sh b/update.sh
index ff5d2422df42..ba0f16d60efc 100755
--- a/update.sh
+++ b/update.sh
@@ -10,11 +10,6 @@ if ! [ "$latest_version" = "$current_version" ]; then
sed -i.bak "s/$current_version/$latest_version/g" PKGBUILD
sed -i.bak "s/pkgrel=[^d.]/pkgrel=1/g" PKGBUILD
./pkgsum.sh
- if which makepkg &> /dev/null; then
- makepkg --printsrcinfo > .SRCINFO
- else
- mksrcinfo
- fi
rm -f *.bak
else
echo Nothing to update.