summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2020-02-15 10:46:08 +1100
committerLuis Aranguren2020-02-15 10:46:08 +1100
commit7705eff7894f1e93465f950889cfa215354b94a9 (patch)
treea88928a7cb2dbf8ad2d402e564391c28de618250
parentd00c716aa3ea6d17c428fac9e4ccbc2e483c467b (diff)
downloadaur-7705eff7894f1e93465f950889cfa215354b94a9.tar.gz
pkgver 1.0.0, restricted python-hidapi dependency because of https://github.com/Coldcard/ckcc-protocol/pull/9
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7836800d35db..8d1bb6350564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-ckcc-protocol
pkgdesc = Python code and command utilities to communicate with coldcard cryptocurrency wallet
- pkgver = 0.8.0
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/Coldcard/ckcc-protocol
arch = any
license = custom
depends = python
- depends = python-hidapi
+ depends = python-hidapi<0.9.0.1
depends = python-click
depends = python-pyaes
depends = python-ecdsa
options = !emptydirs
- source = python-ckcc-protocol-0.8.0.tar.gz::https://github.com/Coldcard/ckcc-protocol/archive/v0.8.0.tar.gz
- sha256sums = 06af95cc750eb4001d9661bd72c741637d7fae37d38b63408f2aca4f715f7aed
+ source = python-ckcc-protocol-1.0.0.tar.gz::https://github.com/Coldcard/ckcc-protocol/archive/v1.0.0.tar.gz
+ sha256sums = 297aee0d24df98357cd1302b64ca560eb29309dd1b3ec981d68a61e399da4cb3
pkgname = python-ckcc-protocol
diff --git a/PKGBUILD b/PKGBUILD
index 0129b126213f..1fa868d119c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname=python-ckcc-protocol
_pkgname=ckcc-protocol
-pkgver=0.8.0
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Python code and command utilities to communicate with coldcard cryptocurrency wallet"
arch=('any')
-depends=(python python-hidapi python-click python-pyaes python-ecdsa)
+depends=(python 'python-hidapi<0.9.0.1' python-click python-pyaes python-ecdsa)
makedepends=()
url="https://github.com/Coldcard/ckcc-protocol"
license=('custom')
options=('!emptydirs')
source=($pkgname-$pkgver.tar.gz::https://github.com/Coldcard/ckcc-protocol/archive/v$pkgver.tar.gz)
-sha256sums=('06af95cc750eb4001d9661bd72c741637d7fae37d38b63408f2aca4f715f7aed')
+sha256sums=('297aee0d24df98357cd1302b64ca560eb29309dd1b3ec981d68a61e399da4cb3')
build() {
cd "$srcdir/$_pkgname-$pkgver"