summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-06-18 19:04:15 +1000
committerLuis Aranguren2019-06-18 19:04:15 +1000
commita284f08a858170c8c7b71c32ccbddee631f5cb17 (patch)
tree2c8de68cf02310155d55eafdd22b715494e04b46
downloadaur-a284f08a858170c8c7b71c32ccbddee631f5cb17.tar.gz
Initial commit, pkgver 0.7.5
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01aab71e71fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ckcc-protocol
+ pkgdesc = Python code and command utilities to communicate with coldcard cryptocurrency wallet
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://github.com/Coldcard/ckcc-protocol
+ arch = any
+ license = custom
+ depends = python
+ options = !emptydirs
+ source = python-ckcc-protocol-0.7.5.tar.gz::https://github.com/Coldcard/ckcc-protocol/archive/v0.7.5.tar.gz
+ sha256sums = 2ab3c4f838999b51d4d7ad5ded43e89a50fe1a5ba5903f36e0188952324a354b
+
+pkgname = python-ckcc-protocol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8fe90310d44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+
+pkgname=python-ckcc-protocol
+_pkgname=ckcc-protocol
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Python code and command utilities to communicate with coldcard cryptocurrency wallet"
+arch=('any')
+depends=(python)
+makedepends=()
+url="https://github.com/Coldcard/ckcc-protocol"
+license=('custom')
+options=('!emptydirs')
+source=($pkgname-$pkgver.tar.gz::https://github.com/Coldcard/ckcc-protocol/archive/v$pkgver.tar.gz)
+sha256sums=('2ab3c4f838999b51d4d7ad5ded43e89a50fe1a5ba5903f36e0188952324a354b')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm0644 51-coinkite.rules "${pkgdir}/usr/lib/udev/rules.d/51-coinkite.rules"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}