summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2020-11-20 16:49:19 -0500
committerStick2020-11-20 16:49:19 -0500
commit07514b1a5355d34b134d49608b13c63d0aa97aee (patch)
tree90954bac1c2e05386e9cd4756ebeffbb24eda804
downloadaur-07514b1a5355d34b134d49608b13c63d0aa97aee.tar.gz
initial build... seems to work?
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b45a006ec9ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-cleantoots
+ pkgdesc = Cleanup your toot history
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://gabnotes.org/cleantoots-clean-your-toot-history/
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python-mastodon
+ depends = python-click
+ depends = python-html2text
+ depends = python-pendulum
+
+pkgname = python-cleantoots
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48c770c5f053
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stick <stick@stma.is>
+pkgname=python-cleantoots
+_name=${pkgname#python-}
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Cleanup your toot history"
+arch=('any')
+url="https://gabnotes.org/cleantoots-clean-your-toot-history/"
+license=('GPL')
+depends=(
+ 'python-mastodon'
+ 'python-click'
+ 'python-html2text'
+ 'python-pendulum'
+)
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('450898a58b905a10a37e8fdf3ce2d825f43baa74e8e516f61362e0f99a2767b6')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}