summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristóf Marussy2021-02-02 17:04:05 +0100
committerKristóf Marussy2021-02-02 17:04:05 +0100
commit008f89fcb7b9c9abf5ce0a7dba3d9ab156c399c0 (patch)
treee1e049585fcc8324ede94eee78028dbcedfe7b14
downloadaur-008f89fcb7b9c9abf5ce0a7dba3d9ab156c399c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c344467cda97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-cleo-git
+ pkgdesc = CliKit is a group of utilities to build beautiful and testable command line interfaces.
+ pkgver = 1.0.0a1.r1.ga772384
+ pkgrel = 1
+ url = https://github.com/sdispater/cleo
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-dephell
+ depends = python-pylev>=1.3
+ depends = python-pylev<2.0
+ depends = python-crashtest>=0.3.0
+ depends = python-crashtest<0.4.0
+ depends = python>=3.6
+ depends = python<4.0
+ provides = python-cleo
+ conflicts = python-cleo
+ source = cleo::git+https://github.com/sdispater/cleo
+ sha256sums = SKIP
+
+pkgname = python-cleo-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e27fb4b590df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Kristóf Marussy <kristof@marussy.com>
+# Contributor: Byeonghoon Yoo <bh322yoo@gmail.com>
+
+_pkgname=cleo
+pkgname=python-cleo-git
+pkgver=1.0.0a1.r1.ga772384
+pkgrel=1
+pkgdesc="CliKit is a group of utilities to build beautiful and testable command line interfaces."
+arch=('any')
+provides=("python-cleo")
+conflicts=('python-cleo')
+url="https://github.com/sdispater/${_pkgname}"
+license=('MIT')
+depends=('python-pylev>=1.3' 'python-pylev<2.0' 'python-crashtest>=0.3.0' 'python-crashtest<0.4.0' 'python>=3.6' 'python<4.0')
+makedepends=('git' 'python-dephell')
+source=("${_pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}"/${_pkgname}
+
+ # poetry-generated setup.py are fatally broken, see:
+ # https://github.com/sdispater/poetry/issues/866
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+build(){
+ cd "${srcdir}"/${_pkgname}
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"/${_pkgname}
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+