summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKristóf Marussy2022-06-16 02:18:54 +0200
committerKristóf Marussy2022-06-16 02:18:54 +0200
commite66a96ffef6f6c1371065bd2451d56c8a7290d2f (patch)
tree40ab9eb2d188f73859a042a14db55aed1d101f6e
parent0d22872afa2969e101f4c07a7a479f12f7d89ae1 (diff)
downloadaur-e66a96ffef6f6c1371065bd2451d56c8a7290d2f.tar.gz
fix package()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92ffb8b9c50a..0de67860dc98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-cleo-git
pkgdesc = Cleo allows you to create beautiful and testable command-line interfaces.
pkgver = 1.0.0a5.r7.g9e8ecbe
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sdispater/cleo
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 3bd53bbf5c7b..bba2a9af8c0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=cleo
pkgname=python-cleo-git
pkgver=1.0.0a5.r7.g9e8ecbe
-pkgrel=1
+pkgrel=2
pkgdesc="Cleo allows you to create beautiful and testable command-line interfaces."
arch=('any')
provides=("python-cleo")
@@ -34,7 +34,7 @@ check() {
package() {
cd "${srcdir}"/${_pkgname}
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m pyproject2setuppy install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}