summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2021-06-17 11:31:09 +0600
committerMubashshir2021-06-17 11:31:09 +0600
commit0118c70bf6fcf4759c62dd3067d720afc5ce2025 (patch)
tree002a8b62972a91d115da7aa4f8847af95d67d787
downloadaur-0118c70bf6fcf4759c62dd3067d720afc5ce2025.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e12c4af845c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-cleo-pypi
+ pkgdesc = create beautiful and testable command-line interfaces
+ pkgver = 0.8.1
+ pkgrel = 3
+ url = https://github.com/sdispater/cleo
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-clikit<0.7.0
+ depends = python-clikit>=0.6.0
+ provides = python-cleo=0.8.1
+ conflicts = python-cleo
+ source = cleo-0.8.1.tar.gz::https://files.pythonhosted.org/packages/source/c/cleo/cleo-0.8.1.tar.gz
+ sha256sums = 3d0e22d30117851b45970b6c14aca4ab0b18b1b53c8af57bed13208147e4069f
+
+pkgname = python-cleo-pypi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ebfacab0c9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff7b88f1a7ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# pkg: pypi cleo
+_name=cleo
+pkgname=python-$_name-pypi
+pkgver=0.8.1
+pkgrel=3
+pkgdesc='create beautiful and testable command-line interfaces'
+provides=("python-cleo=$pkgver")
+conflicts=("python-cleo")
+
+arch=(any)
+url=https://github.com/sdispater/cleo
+license=(MIT)
+depends=(
+ 'python'
+ 'python-clikit<0.7.0' #auto-deps
+ 'python-clikit>=0.6.0' #auto-deps
+)
+
+makedepends=(python-setuptools)
+source=("$_name-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('3d0e22d30117851b45970b6c14aca4ab0b18b1b53c8af57bed13208147e4069f')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package()
+{
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}