summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitri Merejkowsky2017-11-01 12:44:23 +0100
committerDimitri Merejkowsky2017-11-01 12:44:23 +0100
commit34aa1206ba7281cd317d369f69e1747e63319b63 (patch)
treeeaf0436efb86c0a95dfb235dc860605fb6b80eba
downloadaur-34aa1206ba7281cd317d369f69e1747e63319b63.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b98666be1db9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-cli-ui
+ pkgdesc = Build nice user interfaces in the terminal
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://github.com/TankerApp/python-cli-ui
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python
+ depends = python-colorama
+ depends = python-unidecode
+ depends = python-tabulate
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/13/71/0204da083e1cc542e34f3b385b5dcfcedd6008f00f71451b5cfc9ae5cbff/python-cli-ui-0.6.0.tar.gz
+ md5sums = daccc4fc60379a12b348d0e138a62830
+
+pkgname = python-cli-ui
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cd1c4c079c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92701a9c6b82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dimitri Merejkowsky <d.merej@gmail.com>
+pkgname=python-cli-ui
+pkgver="0.6.0"
+pkgrel=1
+pkgdesc="Build nice user interfaces in the terminal"
+url="http://github.com/TankerApp/python-cli-ui"
+arch=('any')
+license=('MIT')
+depends=('python' 'python-colorama' 'python-unidecode' 'python-tabulate' 'python-setuptools')
+makedepends=('python-setuptools')
+source=('https://files.pythonhosted.org/packages/13/71/0204da083e1cc542e34f3b385b5dcfcedd6008f00f71451b5cfc9ae5cbff/python-cli-ui-0.6.0.tar.gz')
+checkdepends=('python-pytest')
+md5sums=('daccc4fc60379a12b348d0e138a62830')
+
+build() {
+ cd ${srcdir}/python-cli-ui-${pkgver}
+ python setup.py build
+}
+
+check() {
+ cd ${srcdir}/python-cli-ui-${pkgver}
+ pytest
+}
+
+package() {
+ cd ${srcdir}/python-cli-ui-${pkgver}
+ python setup.py install --root=$pkgdir/ --optimize=1
+
+ # license
+ mkdir -p $pkgdir/usr/share/licenses/python-cli-ui
+ install LICENSE $pkgdir/usr/share/licenses/python-cli-ui/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: