summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfzerorubigd2017-07-17 09:28:05 +0430
committerfzerorubigd2017-07-17 09:28:05 +0430
commite85f9e9d5dbef2e9cc3ba6ef6e809b52fbb5d41d (patch)
tree90a99b1a83c5e96693b1bdaa6f70348e58f88856
downloadaur-e85f9e9d5dbef2e9cc3ba6ef6e809b52fbb5d41d.tar.gz
initialize the package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD21
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b494684a78d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-cli_helpers
+ pkgdesc = Python helpers for common CLI tasks.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/dbcli/cli_helpers
+ arch = any
+ license = BSD
+ depends = python
+ provides = python-cli_helpers
+ options = !emptydirs
+ source = python-cli_helpers-0.2.2.zip::https://github.com/dbcli/cli_helpers/archive/v0.2.2.zip
+ md5sums = fba797154253a45c62ef7c37ea69f9f8
+
+pkgname = python-cli_helpers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0045cadbfc4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.xz
+*.zip
+*.deb
+*.tar.gz
+*.tar.gz.asc
+*.tgz
+*.bz2
+/pkg
+/src
+*.gz
+rc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8268ab4abae4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: fzerorubigd <fzero@rubi.gd>
+_pkgmain=cli_helpers
+pkgname=python-$_pkgmain
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Python helpers for common CLI tasks."
+arch=('any')
+url="https://github.com/dbcli/cli_helpers"
+license=('BSD')
+groups=()
+depends=('python')
+provides=('python-cli_helpers')
+options=(!emptydirs)
+source=($pkgname-$pkgver.zip::https://github.com/dbcli/cli_helpers/archive/v${pkgver}.zip)
+
+package() {
+ cd "$srcdir/$_pkgmain-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+md5sums=('fba797154253a45c62ef7c37ea69f9f8')