summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrice Waegeneire2016-01-09 18:44:20 +0100
committerBrice Waegeneire2016-01-09 18:44:20 +0100
commit842d770aaf1125e4a7289b07f97e5ca2d409cc8f (patch)
tree6e8dc306a39ee3990ac39cd390b122243cdb658e
downloadaur-842d770aaf1125e4a7289b07f97e5ca2d409cc8f.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b65f6af5d0f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 17:42:44 UTC 2016
+pkgbase = python-click
+ pkgdesc = A simple wrapper around optparse for powerful command line utilities
+ pkgver = 5.1
+ pkgrel = 1
+ url = http://click.pocoo.org/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ provides = python-click
+ provides = python2-click
+ conflicts = python-click
+ conflicts = python2-click
+ source = https://pypi.python.org/packages/source/c/click/click-5.1.tar.gz
+ sha256sums = 678c98275431fad324275dec63791e4a17558b40e5a110e20a82866139a85a5a
+
+pkgname = python-click-5.1
+ depends = python
+
+pkgname = python2-click-5.1
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebf4f66b6a85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Brice Waegeneire <bricewge at gmail dot com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Carl George < arch at cgtx dot us >
+
+pkgbase=python-click
+pkgname=("python-click-5.1" "python2-click-5.1")
+_realname=click
+pkgver=5.1
+pkgrel=1
+pkgdesc="A simple wrapper around optparse for powerful command line utilities"
+arch=("any")
+url="http://click.pocoo.org/"
+license=("BSD")
+makedepends=("python-setuptools" "python2-setuptools")
+provides=("python-click" "python2-click")
+conflicts=("python-click" "python2-click")
+source=("https://pypi.python.org/packages/source/c/$_realname/$_realname-$pkgver.tar.gz")
+sha256sums=('678c98275431fad324275dec63791e4a17558b40e5a110e20a82866139a85a5a')
+
+prepare() {
+ cp -a $_realname-$pkgver{,-python2}
+}
+
+build() {
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_realname}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-click-5.1() {
+ depends=("python")
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_python2-click-5.1() {
+ depends=("python2")
+ cd "${srcdir}/${_realname}-${pkgver}-python2"
+ python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}