summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Asuncion2016-12-17 08:48:10 -0800
committerJeremy Asuncion2016-12-17 08:48:10 -0800
commit0ee9fcd4084a37bcb2b151cddc52cff2028118e8 (patch)
tree88d60643d1d05b7492c07e77edebae7ff640a67c
downloadaur-0ee9fcd4084a37bcb2b151cddc52cff2028118e8.tar.gz
Renamed directories to correct naming scheme
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bbaefacf661
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-click-completion
+ pkgdesc = Fish, Bash, Zsh, and PowerShell completion for Click.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/click-contrib/click-completion
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-jinja
+ source = https://github.com/click-contrib/click-completion/archive/0.2.1.tar.gz
+ md5sums = 68b1261ab229145dc5d0ec685d137aad
+
+pkgname = python-click-completion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25011d7a65f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# vim: set ft=sh ts=4 sw=4 sts=4 et:
+# Maintainer: Jeremy Asuncion <jeremyasuncion808@gmail.com>
+
+_name=click-completion
+pkgname=python-click-completion
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Fish, Bash, Zsh, and PowerShell completion for Click.'
+arch=(any)
+url='https://github.com/click-contrib/click-completion'
+license=(MIT)
+depends=(python python-click python-jinja)
+makedepends=(python-setuptools)
+source=("https://github.com/click-contrib/${_name}/archive/${pkgver}.tar.gz")
+md5sums=(68b1261ab229145dc5d0ec685d137aad)
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install -O1 --skip-build --prefix=/usr --root="${pkgdir}"
+}