summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Laker2019-09-09 00:14:54 -0400
committerKyle Laker2019-09-09 00:14:54 -0400
commitdf03d048004ad3a261dc412a9d314707d646f4e2 (patch)
treea5da7ce28420494be363cacac154ce23612302e8
parentb3c0ea85a2e4494b32ba5ce4b2f54feeb7d0e025 (diff)
downloadaur-df03d048004ad3a261dc412a9d314707d646f4e2.tar.gz
Updated 0.4.1 -> 0.5.1
Additionally, took over as maintainer.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ba7bc92b196..b497ae1d8f4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-click-completion
pkgdesc = Fish, Bash, Zsh, and PowerShell completion for Click.
- pkgver = 0.4.1
+ pkgver = 0.5.1
pkgrel = 1
url = https://github.com/click-contrib/click-completion
arch = any
@@ -9,8 +9,8 @@ pkgbase = python-click-completion
depends = python
depends = python-click
depends = python-jinja
- source = https://github.com/click-contrib/click-completion/archive/0.4.1.tar.gz
- sha512sums = e4b9faf0706b49294b3cc36636f9b329acbe5fbc030d53c7057a263cd26a34438516885ddf31acfc6fc1db59fb082418778df66b926e113cc16954ec5c38edf0
+ source = https://files.pythonhosted.org/packages/source/c/click-completion/click-completion-0.5.1.tar.gz
+ sha512sums = 7d84eaca50f78ce1abfb485d3d63c3625d1454ae54c86eeebf03e5aeb8fcbb1f3afcac8202b1c44549aaecb2fc480491a5ce082bec30b1cab9e731acc1875cc2
pkgname = python-click-completion
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index e66114f773c8..42fafdaa32bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Jeremy Asuncion <jeremyasuncion808@gmail.com>
-
-_name='click-completion'
+# Maintainer: Kyle Laker <kyle+aur at laker dot email>
+# Contributor: Jeremy Asuncion <jeremyasuncion808@gmail.com>
pkgname='python-click-completion'
-pkgver='0.4.1'
+_name="${pkgname#python-}"
+pkgver='0.5.1'
pkgrel=1
pkgdesc='Fish, Bash, Zsh, and PowerShell completion for Click.'
arch=('any')
@@ -10,8 +10,8 @@ url='https://github.com/click-contrib/click-completion'
license=('MIT')
depends=('python' 'python-click' 'python-jinja')
makedepends=('python-setuptools')
-source=("https://github.com/click-contrib/${_name}/archive/${pkgver}.tar.gz")
-sha512sums=('e4b9faf0706b49294b3cc36636f9b329acbe5fbc030d53c7057a263cd26a34438516885ddf31acfc6fc1db59fb082418778df66b926e113cc16954ec5c38edf0')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('7d84eaca50f78ce1abfb485d3d63c3625d1454ae54c86eeebf03e5aeb8fcbb1f3afcac8202b1c44549aaecb2fc480491a5ce082bec30b1cab9e731acc1875cc2')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -20,5 +20,5 @@ build() {
package() {
cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install -O1 --skip-build --prefix=/usr --root="${pkgdir}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}