summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikkel Oscar Lyderik2016-05-24 07:31:37 +0200
committerMikkel Oscar Lyderik2016-05-24 07:31:37 +0200
commit6aaebff12517872101267affe71d47ab77ee5460 (patch)
treebf45a6341a42c89da3d5bbe95d9b7f6ee435e721
downloadaur-6aaebff12517872101267affe71d47ab77ee5460.tar.gz
Init commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e66522509fdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+
+# Generated by mksrcinfo v8
+# Tue May 24 05:31:27 UTC 2016
+pkgbase = python-clickclick
+ pkgdesc = Click command line utilities
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/zalando/python-clickclick
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-yaml
+ source = http://pypi.python.org/packages/source/c/clickclick/clickclick-1.0.tar.gz
+ md5sums = 9429dede90d390fc06a74c002bb9e05c
+
+pkgname = python-clickclick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9d0bbe0707e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mikkel Oscar Lyderik <mikkeloscar at gmail dot com>
+
+pkgname=python-clickclick
+_pkgname=clickclick
+pkgver=1.0
+pkgrel=1
+pkgdesc="Click command line utilities"
+url="https://github.com/zalando/python-clickclick"
+license=('APACHE')
+arch=('any')
+makedepends=('python-setuptools')
+depends=('python' 'python-click' 'python-yaml')
+source=("http://pypi.python.org/packages/source/c/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('9429dede90d390fc06a74c002bb9e05c')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}"
+}
+
+# vim:set sw=2 sts=2 ft=sh et: