summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-10-03 10:26:41 -0600
committerMark Wagie2020-10-03 10:26:41 -0600
commitaaafc0481aadea409dc0dbbf89c71a7294d636f2 (patch)
tree5870c0e4626e8c8e1733d2927fbda58496c7bf49
downloadaur-aaafc0481aadea409dc0dbbf89c71a7294d636f2.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..017c6dee4e3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-clickgen
+ pkgdesc = X11 & Windows cursor building API
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://github.com/ful1e5/clickgen
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pip
+ depends = python-pillow
+ depends = libx11
+ depends = libxcursor
+ depends = libpng
+ source = https://pypi.org/packages/source/c/clickgen/clickgen-1.1.6.tar.gz
+ sha256sums = e5197dd6b8e9bedb0ee76b3b46c2db54f0edbbd260fda17ab1bccb57eff0dfb5
+
+pkgname = python-clickgen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb3459d9e050
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-clickgen
+_name=${pkgname#python-}
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="X11 & Windows cursor building API"
+arch=('any')
+url="https://github.com/ful1e5/clickgen"
+license=('MIT')
+depends=('python-pillow' 'libx11' 'libxcursor' 'libpng')
+makedepends=('python-setuptools' 'python-pip')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e5197dd6b8e9bedb0ee76b3b46c2db54f0edbbd260fda17ab1bccb57eff0dfb5')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}