summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-01-24 08:16:10 -0700
committerMark Wagie2021-01-24 08:16:10 -0700
commitdcdc83c9ad466f15d27aefa96ce4a24f45a46466 (patch)
tree5cce4d0495002e18273be25de758b8a67cde0a97
parent6fd559fc11271d27edb09e6bf1575e48431bc933 (diff)
downloadaur-dcdc83c9ad466f15d27aefa96ce4a24f45a46466.tar.gz
1.1.8
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD5
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef7d99a92398..af654139aa4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-clickgen
pkgdesc = X11 & Windows cursor building API
- pkgver = 1.1.7
+ pkgver = 1.1.8
pkgrel = 1
url = https://github.com/ful1e5/clickgen
arch = any
@@ -11,8 +11,8 @@ pkgbase = python-clickgen
depends = libx11
depends = libxcursor
depends = libpng
- source = https://pypi.org/packages/source/c/clickgen/clickgen-1.1.7.tar.gz
- sha256sums = 5aaaedd34d7115976db9b82e1d57492d7aceedd5c00a43155d86cbb11073444e
+ source = https://pypi.org/packages/source/c/clickgen/clickgen-1.1.8.tar.gz
+ sha256sums = ec853050a433dac806cbf7b428427a9ae6fd2536012bc3e5e8e194789396f9b2
pkgname = python-clickgen
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 97f82e667ac0..72746a40893f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-clickgen
_name=${pkgname#python-}
-pkgver=1.1.7
+pkgver=1.1.8
pkgrel=1
pkgdesc="X11 & Windows cursor building API"
arch=('any')
@@ -10,7 +10,7 @@ license=('MIT')
depends=('python-pillow' 'libx11' 'libxcursor' 'libpng')
makedepends=('python-setuptools' 'python-pip')
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('5aaaedd34d7115976db9b82e1d57492d7aceedd5c00a43155d86cbb11073444e')
+sha256sums=('ec853050a433dac806cbf7b428427a9ae6fd2536012bc3e5e8e194789396f9b2')
build() {
cd "$_name-$pkgver"
@@ -19,6 +19,7 @@ build() {
package() {
cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"