summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-12-26 06:54:06 -0700
committerMark Wagie2023-12-26 06:54:06 -0700
commitf44e7c7f0ef3d8e2f4295d9a392d6c519431ea57 (patch)
tree540501ef564f1bfbd9255864c2926af8f59cebec
parent0bd9b612ad708167a226c51192d893fa1db45e9a (diff)
downloadaur-f44e7c7f0ef3d8e2f4295d9a392d6c519431ea57.tar.gz
2.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58df57ab8808..625f0f5b7577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-clickgen
pkgdesc = X11 & Windows cursor building API
- pkgver = 2.1.9
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/ful1e5/clickgen
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-clickgen
depends = python-pillow
depends = python-toml
depends = python-yaml
- source = clickgen-2.1.9.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v2.1.9.tar.gz
- sha256sums = 6eee41e29390b5805916231d662a94e071cb4217d6174027436ed69fc22760cf
+ source = clickgen-2.2.0.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v2.2.0.tar.gz
+ sha256sums = d12b70494e6ae6eb626efee2ef97bdb5007bf27e1037c28bf71ab8c67f157eed
pkgname = python-clickgen
diff --git a/PKGBUILD b/PKGBUILD
index 63bfdc7797b4..c7dfb5a20338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=python-clickgen
_name=${pkgname#python-}
-pkgver=2.1.9
+pkgver=2.2.0
pkgrel=1
pkgdesc="X11 & Windows cursor building API"
arch=('any')
@@ -9,16 +9,16 @@ url="https://github.com/ful1e5/clickgen"
license=('MIT')
depends=('python-attrs' 'python-numpy' 'python-pillow' 'python-toml' 'python-yaml')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-source=("$_name-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('6eee41e29390b5805916231d662a94e071cb4217d6174027436ed69fc22760cf')
+source=("${_name}-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('d12b70494e6ae6eb626efee2ef97bdb5007bf27e1037c28bf71ab8c67f157eed')
build() {
- cd "$_name-$pkgver"
+ cd "${_name}-$pkgver"
python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
+ cd "${_name}-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"