summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-26 09:33:36 -0600
committerMark Wagie2022-03-26 09:33:36 -0600
commitfd2e36b88872f8c1e8cd5e52739f4c86f2a846c4 (patch)
treece7a3827d440b7fbdfb75333a93acfd3295a7e5c
parentac60cf55db0b1cf42b2b948ff6ee107788454944 (diff)
downloadaur-fd2e36b88872f8c1e8cd5e52739f4c86f2a846c4.tar.gz
1.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14515e978326..f090616bb2c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = python-clickgen
pkgdesc = X11 & Windows cursor building API
- pkgver = 1.1.9
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/ful1e5/clickgen
- arch = any
+ arch = x86_64
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-pillow
depends = libx11
depends = libxcursor
depends = libpng
- source = https://pypi.org/packages/source/c/clickgen/clickgen-1.1.9.tar.gz
- sha256sums = 2567bae2c08a45e4381954eb5bb76252519ed208ebe6f3d43cca83c11a854b9d
+ provides = xcursorgen.so
+ source = clickgen-1.2.0.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v1.2.0.tar.gz
+ sha256sums = 26d5fccced30a635e9a113bac2c71f7fcea95cb73cd904ae1405c16ef172b88f
pkgname = python-clickgen
diff --git a/PKGBUILD b/PKGBUILD
index 0ab3cf686520..942f391f93bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-clickgen
_name=${pkgname#python-}
-pkgver=1.1.9
+pkgver=1.2.0
pkgrel=1
pkgdesc="X11 & Windows cursor building API"
-arch=('any')
+arch=('x86_64')
url="https://github.com/ful1e5/clickgen"
license=('MIT')
depends=('python-pillow' 'libx11' 'libxcursor' 'libpng')
-makedepends=('python-setuptools')
-source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('2567bae2c08a45e4381954eb5bb76252519ed208ebe6f3d43cca83c11a854b9d')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+provides=('xcursorgen.so')
+source=("$_name-$pkgver.tar.gz::https://github.com/ful1e5/clickgen/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('26d5fccced30a635e9a113bac2c71f7fcea95cb73cd904ae1405c16ef172b88f')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
+
+ make -C src/xcursorgen
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -Dm644 src/xcursorgen/xcursorgen.so -t "${pkgdir}${site_packages}/$_name/"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "$site_packages/$_name-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}