summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorByeonghoon Yoo2020-12-20 20:45:22 +0900
committerByeonghoon Yoo2020-12-20 20:45:22 +0900
commite18a338e9a42cf6f3ff86801d20f101e8152df71 (patch)
tree3aa545274de462e1e1bd715e0215583ee39434e8
parenta7f2819f81408acc8134c0507e30bfd6fce68a84 (diff)
downloadaur-e18a338e9a42cf6f3ff86801d20f101e8152df71.tar.gz
Use dephell
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a5c7cb14730..f58fd2288f93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = python-clikit-git
pkgdesc = CliKit is a group of utilities to build beautiful and testable command line interfaces.
pkgver = r114.1da34f1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sdispater/clikit
arch = any
license = MIT
- checkdepends = python-pytest-mock>=2.0.0
- makedepends = python-poetry>=1.0.0
- makedepends = python-pip
+ makedepends = python-dephell
depends = python-pastel>=0.2.0
depends = python-pastel<0.3.0
depends = python-pylev>=1.3
diff --git a/PKGBUILD b/PKGBUILD
index 2f83e5ec25a5..70d82d1ad792 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=clikit
pkgname=python-clikit-git
pkgver=r114.1da34f1
-pkgrel=1
+pkgrel=2
pkgdesc="CliKit is a group of utilities to build beautiful and testable command line interfaces."
arch=('any')
provides=('python-clikit')
@@ -11,11 +11,18 @@ confilicts=('python-clikit')
url="https://github.com/sdispater/${_pkgname}"
license=('MIT')
depends=('python-pastel>=0.2.0' 'python-pastel<0.3.0' 'python-pylev>=1.3' 'python-pylev<2.0' 'python-crashtest>=0.3.0' 'python-crashtest<0.4.0' 'python>=3.6' 'python<4.0')
-makedepends=('python-poetry>=1.0.0' 'python-pip')
-checkdepends=('python-pytest-mock>=2.0.0')
+makedepends=('python-dephell')
source=("${_pkgname}::${url//https/git}")
sha256sums=('SKIP')
+prepare() {
+ cd "${srcdir}"/${_pkgname}
+
+ # poetry-generated setup.py are fatally broken, see:
+ # https://github.com/sdispater/poetry/issues/866
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -23,13 +30,12 @@ pkgver() {
build(){
cd "${srcdir}"/${_pkgname}
- poetry build
+ python setup.py build
}
package() {
cd "${srcdir}"/${_pkgname}
- echo "${pkgdir}"
- pip install --no-deps --ignore-installed --no-cache-dir --prefix "${pkgdir}/usr" dist/clikit-$(poetry version -s)-py2.py3-none-any.whl
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}