summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroysstu2018-08-16 19:26:29 +0200
committeroysstu2018-08-16 19:26:29 +0200
commit691a95e39d0991f8e28632f3b891b2029bb18bb9 (patch)
treed424baafa6ea3fe9af15c9e36090151a9fb23868
downloadaur-691a95e39d0991f8e28632f3b891b2029bb18bb9.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd6ae8c7583e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-climin-git
+ pkgdesc = Optimizers for machine learning
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/BRML/climin
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ source = git://github.com/BRML/climin.git
+ sha512sums = SKIP
+
+pkgname = python-climin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f91690983a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Oystein Sture <oysstu@gmail.com>
+# Contributor:
+
+pkgname=python-climin-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Optimizers for machine learning"
+arch=("any")
+license=("BSD")
+url="https://github.com/BRML/climin"
+depends=('python' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+source=("git://github.com/BRML/climin.git")
+sha512sums=("SKIP")
+
+build() {
+ cd climin
+ python setup.py build
+}
+
+package() {
+ cd climin
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}