summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2020-11-25 02:32:32 +0100
committerjakob2020-11-25 02:32:32 +0100
commit57fc58b23ec7ce703d00c9d49c77e2724600e72e (patch)
tree52d0bddcb081e562bf92cc5719e73f6e716cd828
downloadaur-57fc58b23ec7ce703d00c9d49c77e2724600e72e.tar.gz
0.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76551868133c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-clintermission
+ pkgdesc = Non-fullscreen command-line selection menu
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/sebageek/clintermission
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = python-prompt_toolkit
+ source = https://files.pythonhosted.org/packages/source/c/clintermission/clintermission-0.2.0.tar.gz
+ sha256sums = 42b0ffb031c010c1a2a8ace9c560d631abb3b4ba74cc67ff4bcae1fff182a876
+
+pkgname = python-clintermission
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6af5033c4f1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: jakob <grandchild@gmx.net>
+
+_pkgname=clintermission
+pkgname=python-${_pkgname}
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Non-fullscreen command-line selection menu"
+arch=(any)
+url="https://github.com/sebageek/clintermission"
+license=('Apache')
+depends=(python python-prompt_toolkit)
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('42b0ffb031c010c1a2a8ace9c560d631abb3b4ba74cc67ff4bcae1fff182a876')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}