summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGroctel2021-04-04 18:52:06 +0200
committerGroctel2021-04-04 18:52:06 +0200
commitc30cd200a91af840572bc828b08b352296da8454 (patch)
tree8ea402264ecc6759fb460a2b6b7ce6e9822f3f7c
downloadaur-c30cd200a91af840572bc828b08b352296da8454.tar.gz
First commit. Version 0.7.0
It throws exceptions on install but that doesn't prevent it from continuing. Since this is a dependency for manim, I'm going to leave it be unless it breaks its installation tests
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9deb2f653e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-cloup
+ pkgdesc = Cloup (= Click + groups) contains a set of Click extensions for multiple purposes.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/janLuke/cloup
+ arch = any
+ license = MIT
+ source = https://files.pythonhosted.org/packages/5e/41/9cb38267c5dbec89a07cdb3549561d94ed6e81f3a6b62954358aaeb27d76/cloup-0.7.0.tar.gz
+ sha512sums = af1734fd4bbf47fd329cd170d9c2cd5edf2e98a505c3b7593f870ac34180074fee63465b8a41437e3c5813b369fed460029bd604c539aa37cd1b5ebec21291e7
+
+pkgname = python-cloup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70bdd21e4d62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Groctel <aur@taxorubio.com>
+pkgname=python-cloup
+_name=cloup
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Cloup (= Click + groups) contains a set of Click extensions for multiple purposes."
+arch=('any')
+url="https://github.com/janLuke/cloup"
+license=('MIT')
+# makedepends=(
+# )
+provides=()
+source=("https://files.pythonhosted.org/packages/5e/41/9cb38267c5dbec89a07cdb3549561d94ed6e81f3a6b62954358aaeb27d76/cloup-0.7.0.tar.gz")
+sha512sums=('af1734fd4bbf47fd329cd170d9c2cd5edf2e98a505c3b7593f870ac34180074fee63465b8a41437e3c5813b369fed460029bd604c539aa37cd1b5ebec21291e7')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+