summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2022-02-02 13:48:33 +0100
committerXyne2022-02-02 15:44:12 +0100
commitb465ef68b0e94ac3892ac2ee65834bf8ba0284ca (patch)
tree66dc37ba72d2d5dfb45e8fabc7578976a4159b1d
downloadaur-b465ef68b0e94ac3892ac2ee65834bf8ba0284ca.tar.gz
Initialize.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..204dc1941cd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-cmappy-git
+ pkgdesc = Tools for interacting with .gctx and .gct and other Connectivity Map resources.
+ pkgver = 3.3.0.r128.g69f51c0
+ pkgrel = 1
+ url = https://github.com/cmap/${_name}
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-h5py
+ depends = python-requests
+ source = cmapPy::git+https://github.com/cmap/cmapPy
+ sha512sums = SKIP
+
+pkgname = python-cmappy-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea7b93dff7e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Xyne <xyne at archlinux dot org>
+_name=cmapPy
+pkgname=python-${_name,,}-git
+pkgver=3.3.0.r128.g69f51c0
+pkgrel=1
+pkgdesc='Tools for interacting with .gctx and .gct and other Connectivity Map resources.'
+url='https://github.com/cmap/${_name}'
+arch=('any')
+license=('BSD')
+depends=('python' 'python-numpy' 'python-pandas' 'python-h5py' 'python-requests')
+makedepends=('git')
+source=(${_name}::git+https://github.com/cmap/${_name})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package ()
+{
+ cd "$_name"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+# vim: ts=2 sw=2 et: