summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2021-05-22 12:23:34 +0200
committerCayetano Santos2021-05-22 12:23:34 +0200
commit283738458d23377d986bae1b1d894254afa7e0d8 (patch)
treeed23e0719e026d0c8162fc1eacd0abeedee5866a
downloadaur-283738458d23377d986bae1b1d894254afa7e0d8.tar.gz
First commit, includes all necessary files
-rw-r--r--.SRCINFO20
-rw-r--r--.gitlab-ci.yml26
-rw-r--r--PKGBUILD29
-rw-r--r--readme.org10
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5497fa23f72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-cocotb-bus
+ pkgdesc = Pre-packaged testbenching tools and reusable bus interfaces for cocotb
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/cocotb/cocotb-bus/
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = gcc
+ depends = python
+ depends = python-setuptools
+ optdepends = iverilog: for simulating verilog designs
+ optdepends = ghdl: for simulating VHDL designs
+ optdepends = gtkwave: for visualizing waveforms
+ options = !emptydirs
+ source = git+https://github.com/cocotb/cocotb-bus#tag=v0.1.1
+ md5sums = SKIP
+
+pkgname = python-cocotb-bus
+
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..45e4f226b376
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,26 @@
+# * Prepare
+
+image: archlinux
+
+variables:
+ DOSUDO: "notroot ALL=(ALL) NOPASSWD: ALL"
+
+stages:
+ - test
+
+before_script:
+ - pacman --noconfirm -Syu
+ - pacman --noconfirm -S sudo git fakeroot binutils
+ - useradd -m notroot
+ - echo "$DOSUDO" > /etc/sudoers.d/notroot
+
+# * Test
+
+build-package:
+ stage: test
+ script:
+ - cd /home/notroot
+ - su notroot -c "git clone https://aur.archlinux.org/python-cocotb-bus.git"
+ - cd python-cocotb-bus
+ - su notroot -c "makepkg --noconfirm --syncdeps --rmdeps --install --clean"
+ - python -c 'import cocotb-bus; print("All OK")'
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24fc2cccf786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: csantosb <csantosb dot inventati dot org>
+pkgname=python-cocotb-bus
+pkgver=0.1
+pkgrel=1
+pkgdesc="Pre-packaged testbenching tools and reusable bus interfaces for cocotb"
+arch=('any')
+url="https://github.com/cocotb/cocotb-bus/"
+license=('BSD')
+depends=('python' 'python-setuptools')
+
+makedepends=('git' 'gcc')
+optdepends=('iverilog: for simulating verilog designs'
+ 'ghdl: for simulating VHDL designs'
+ 'gtkwave: for visualizing waveforms')
+
+options=(!emptydirs)
+source=("git+https://github.com/cocotb/cocotb-bus#tag=v${pkgver}.${pkgrel}")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/cocotb-bus"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/cocotb-bus"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}
diff --git a/readme.org b/readme.org
new file mode 100644
index 000000000000..4eb688ab3977
--- /dev/null
+++ b/readme.org
@@ -0,0 +1,10 @@
+#+TITLE: Python-cocotb-bus AUR package
+
+[[https://gitlab.com/aur-packages/python-cocotb/-/commits/master][https://gitlab.com/aur-packages/python-cocotb-bus/badges/master/pipeline.svg]]
+
+[[https://docs.cocotb.org/en/latest/][Cocotb]] is a coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python.
+[[https://github.com/cocotb/cocotb-bus][Cocotb-bus]] are pre-packaged testbenching tools and reusable bus interfaces for [[https://github.com/cocotb/cocotb-bus][Cocotb]].
+
+This [[https://wiki.archlinux.org/index.php/Arch_Build_System][PKGBUILD]] provides a way to build a package suitable for [[https://www.archlinux.org/][Archlinux]].
+
+This project lives in [[https://gitlab.com/aur-packages/python-cocotb-bus][gitlab.com]] and in the [[https://aur.archlinux.org/packages/python-cocotb-bus/][aur]]. The included =yml= file tests the [[https://gitlab.com/aur-packages/python-cocotb-bus/pipelines][build]] process.