summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Koch2023-08-11 10:49:11 +0200
committerMarkus Koch2023-08-11 10:49:11 +0200
commitdad2acd7234e8e90f75608605c1be73fef58a64b (patch)
tree58f5ab6179811113818096dccfe5eb1ac61b752f
downloadaur-dad2acd7234e8e90f75608605c1be73fef58a64b.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1fdada62580
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-cocotb-coverage-git
+ pkgdesc = Functional Coverage and Constrained Randomization Extensions for Cocotb
+ pkgver = 1.1.30.g21330f3
+ pkgrel = 1
+ url = https://github.com/mciepluc/cocotb-coverage
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-cocotb
+ depends = python-pyaml
+ depends = python-constraint
+ source = git+https://github.com/mciepluc/cocotb-coverage
+ sha256sums = SKIP
+
+pkgname = python-cocotb-coverage-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ecc3761ba6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Markus Koch <markus@notsyncing.net>
+pkgname=python-cocotb-coverage-git
+pkgver=1.1.30.g21330f3
+pkgrel=1
+pkgdesc="Functional Coverage and Constrained Randomization Extensions for Cocotb"
+arch=('any')
+url="https://github.com/mciepluc/cocotb-coverage"
+license=('MIT')
+depends=('python-cocotb' 'python-pyaml' 'python-constraint')
+makedepends=('python-setuptools')
+
+source=("git+https://github.com/mciepluc/cocotb-coverage")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/cocotb-coverage"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/cocotb-coverage"
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir/" --optimize=1
+}