summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-03-08 11:51:55 +0100
committerCayetano Santos2020-03-08 12:46:21 +0100
commit18656a073bd5fc76e4eb63b366e9fd6622d6fa28 (patch)
tree9d322a3b46e543c9dad191bba77334223b527f32
downloadaur-18656a073bd5fc76e4eb63b366e9fd6622d6fa28.tar.gz
First version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8f556aee1ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cocotb
+ pkgdesc = Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python
+ pkgver = r2445.e9490fab
+ pkgrel = 1
+ url = https://github.com/cocotb
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ optdepends = iverilog: for simulating verilog designs
+ optdepends = ghdl: for simulating VHDL designs
+ provides = cocotb
+ conflicts = cocotb
+ options = !emptydirs
+ source = git+https://github.com/cocotb/cocotb
+ md5sums = SKIP
+
+pkgname = cocotb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db8723919a81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: csantosb <csantosb dot inventati dot org>
+pkgname=cocotb-git
+pkgver=r2445.e9490fab
+pkgrel=1
+pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python"
+arch=('any')
+url="https://github.com/cocotb/cocotb"
+license=('BSD')
+conflicts=(cocotb)
+provides=('cocotb')
+depends=('python')
+
+makedepends=('git')
+optdepends=('iverilog: for simulating verilog designs'
+ 'ghdl: for simulating VHDL designs')
+
+options=(!emptydirs)
+source=('git+https://github.com/cocotb/cocotb')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/cocotb"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/cocotb"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+} \ No newline at end of file