summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-09-22 17:03:19 +0200
committerwillemw122023-09-22 17:03:19 +0200
commit19821ecad7829456059afbe9e91bbb983caf2aa7 (patch)
tree6415ef4097329f4e75bf2d4de65f98f432361206
parent50057d570d76563a85e59502902352d1aa753853 (diff)
downloadaur-19821ecad7829456059afbe9e91bbb983caf2aa7.tar.gz
Update to standards based install
Add git clean.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d907d34c55c..aeab1250bc91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-code-chat-git
pkgdesc = Source code to HTML translator (literate programming)
- pkgver = 1.9.0.r5.g05f02b3
+ pkgver = 1.5.1.r242.g6809e75
pkgrel = 1
url = https://github.com/bjones1/CodeChat
arch = any
license = GPL3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python-docutils
provides = python-code-chat
diff --git a/PKGBUILD b/PKGBUILD
index 90fbf82270c4..09ff1e7e9fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=python-code-chat
-pkgname=$_pkgname-git
-pkgver=1.9.0.r5.g05f02b3
+pkgname=python-code-chat-git
+pkgver=1.5.1.r242.g6809e75
pkgrel=1
-pkgdesc="Source code to HTML translator (literate programming)"
-arch=('any')
-url="https://github.com/bjones1/CodeChat"
-license=('GPL3')
-depends=('python-docutils')
-makedepends=('git' 'python-setuptools')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+pkgdesc='Source code to HTML translator (literate programming)'
+arch=(any)
+url=https://github.com/bjones1/CodeChat
+license=(GPL3)
+depends=(python-docutils)
+makedepends=(git python-build python-installer python-wheel python-setuptools)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
md5sums=('SKIP')
pkgver() {
+ git -C $pkgname describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ git -C $pkgname clean -dfx
+}
+
+build() {
cd $pkgname
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-