summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-03-20 23:45:20 +0100
committerjose17112017-03-20 23:45:20 +0100
commit459ffbcc23e5db355018437868f5a392ca3b6692 (patch)
treee1fa25cf5d4fe293e97ae0201d6af6234d430f76
downloadaur-python-codebug_tether.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d3e4ecae663
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Mar 20 22:45:04 UTC 2017
+pkgbase = python-codebug_tether
+ pkgdesc = Control CodeBug over Serial USB.
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/codebugtools/codebug_tether
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/c/codebug_tether/codebug_tether-0.9.1.tar.gz
+ md5sums = 507c8f489200df0695197765992b8800
+
+pkgname = python-codebug_tether
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..043d2e7496df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=('python-codebug_tether')
+_module='codebug_tether'
+pkgver='0.9.1'
+pkgrel=1
+pkgdesc="Control CodeBug over Serial USB."
+url="https://github.com/codebugtools/codebug_tether"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/c/codebug_tether/codebug_tether-${pkgver}.tar.gz")
+md5sums=('507c8f489200df0695197765992b8800')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}