summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-02 15:05:17 -0500
committerCarlos Aznarán Laos2021-11-02 15:05:17 -0500
commit9ea79ebb25fb3dd77e51373051416b8d48fcaa9f (patch)
treebe711194703a0f1f52074bac50488a02221a1b2f
downloadaur-9ea79ebb25fb3dd77e51373051416b8d48fcaa9f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56f0753e7938
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-codepy
+ pkgdesc = Generate and execute native code at run time, from Python
+ pkgver = 2019.1
+ pkgrel = 1
+ url = https://documen.tician.de/codepy
+ arch = x86_64
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python-cgen
+ depends = boost
+ source = git+https://github.com/inducer/codepy.git?signed#tag=v2019.1
+ validpgpkeys = 900A958D9A0ACA58B1468F2471AA298BCA171145
+ sha512sums = SKIP
+
+pkgname = python-codepy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8880e23ca40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=codepy
+pkgname=python-${_base}
+pkgdesc="Generate and execute native code at run time, from Python"
+pkgver=2019.1
+pkgrel=1
+arch=('x86_64')
+url="https://documen.tician.de/${_base}"
+license=(MIT)
+depends=(python-cgen boost)
+makedepends=(python-setuptools git)
+checkdepends=(python-pytest)
+source=("git+https://github.com/inducer/${_base}.git?signed#tag=v${pkgver}")
+validpgpkeys=("900A958D9A0ACA58B1468F2471AA298BCA171145") # Andreas Kloeckner
+sha512sums=('SKIP')
+
+build() {
+ cd "${_base}"
+ python setup.py build
+}
+
+check() {
+ cd "${_base}"
+ PYTHONPATH="$PWD/build/lib/${_base}/" python -m pytest
+}
+
+package() {
+ cd "${_base}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}