summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-30 17:51:34 -0400
committeracxz2020-05-30 17:51:34 -0400
commiteab7246ee4c5d516e57e793f6a192a22935ae55c (patch)
treecce42ae7e4a89b332026d28f0782c27810e26f34
parentc3894de1344f7a59e9b832d2d4bd25b9da07fd6b (diff)
downloadaur-eab7246ee4c5d516e57e793f6a192a22935ae55c.tar.gz
updpkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c531e62f3d5b..c62e6ca405cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-colcon-core
pkgdesc = Command line tool to build sets of software packages.
- pkgver = 0.3.22
+ pkgver = 0.5.9
pkgrel = 1
- url = https://pypi.org/project/colcon-core
+ url = https://colcon.readthedocs.io/en/released/
arch = any
license = Apache
makedepends = python-setuptools
@@ -15,8 +15,8 @@ pkgbase = python-colcon-core
depends = python-distlib
depends = python-notify2
depends = python-empy
- source = https://files.pythonhosted.org/packages/70/55/2a1effeac1707632ccb8121f920f4b142fa6e43ce967ce17897e94ce5352/colcon-core-0.3.22.tar.gz
- sha256sums = b3f04e14168675914e87fde3d0999279499fe61203109419782408c371f58be1
+ source = python-colcon-core-0.5.9.tar.gz::https://github.com/colcon/colcon-core/archive/0.5.9.tar.gz
+ sha256sums = e657aab632efdb17ba4b5a173d6c8f58ef47120453122081f057a9c878511c9b
pkgname = python-colcon-core
diff --git a/PKGBUILD b/PKGBUILD
index 99fe925d6777..854c7493aad3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
-# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+# Maintainer: acxz <akashpatel2008@yahoo.com>
+# Contributor: Tong Chunli<t.cunly at 163 dot com>
+
pkgname=python-colcon-core
-pkgver=0.3.22
+pkgver=0.5.9
pkgrel=1
pkgdesc="Command line tool to build sets of software packages."
arch=(any)
-url="https://pypi.org/project/colcon-core"
+url="https://colcon.readthedocs.io/en/released/"
license=('Apache')
-depends=('python-pytest' 'python-pytest-runner' 'python-pytest-rerunfailures' 'python-pytest-repeat' 'python-coverage' 'python-pytest-cov' 'python-distlib' 'python-notify2' 'python-empy')
+depends=('python-pytest' 'python-pytest-runner' 'python-pytest-rerunfailures'
+ 'python-pytest-repeat' 'python-coverage' 'python-pytest-cov'
+ 'python-distlib' 'python-notify2' 'python-empy')
makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/70/55/2a1effeac1707632ccb8121f920f4b142fa6e43ce967ce17897e94ce5352/colcon-core-0.3.22.tar.gz)
-sha256sums=('b3f04e14168675914e87fde3d0999279499fe61203109419782408c371f58be1')
+source=("$pkgname-$pkgver.tar.gz"::"https://github.com/colcon/colcon-core/archive/$pkgver.tar.gz")
+sha256sums=('e657aab632efdb17ba4b5a173d6c8f58ef47120453122081f057a9c878511c9b')
-package() {
- cd ${srcdir}/colcon-core-${pkgver}
+_pkgname=colcon-core
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 README.rst -t "$pkgdir/usr/share/doc/$pkgname"
}