summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2020-10-26 14:33:54 +0700
committerAchmad Fathoni2020-10-26 14:33:54 +0700
commit93468e10a6afa5c8369c04586539ed855a104100 (patch)
treedf16284640b5f352a346d1f1bc4c63479e440fc0
parent5b93550f06fbd6617b47f7c9099f868ab655eeb7 (diff)
downloadaur-93468e10a6afa5c8369c04586539ed855a104100.tar.gz
0.2.13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea7e31c61a44..64982bf176a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-colcon-notification
pkgdesc = An extension for colcon-core to provide status notifications.
- pkgver = 0.2.8
+ pkgver = 0.2.13
pkgrel = 1
url = https://pypi.org/project/colcon-notification
arch = any
license = Apache
makedepends = python-setuptools
depends = python-colcon-core
- source = https://files.pythonhosted.org/packages/fc/a7/1944423a15ca14904f45ab504fe5aebcf7430933772637b769998d90a718/colcon-notification-0.2.8.tar.gz
- sha256sums = 3467248415f6acc8f434b3b36b875be3efa76e1166b95852881d9768e6f41c06
+ source = https://files.pythonhosted.org/packages/source/c/colcon-notification/colcon-notification-0.2.13.tar.gz
+ sha256sums = 6aae1ffe73ae956bcb36e330822cd230a2a88c9181b3170aafd1a446638e69b3
pkgname = python-colcon-notification
diff --git a/PKGBUILD b/PKGBUILD
index 08ac643c1ef5..2487eefca722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-notification
-pkgver=0.2.8
+_name=${pkgname:7}
+pkgver=0.2.13
pkgrel=1
pkgdesc="An extension for colcon-core to provide status notifications."
arch=(any)
@@ -8,12 +10,12 @@ url="https://pypi.org/project/colcon-notification"
license=('Apache')
depends=('python-colcon-core')
makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/fc/a7/1944423a15ca14904f45ab504fe5aebcf7430933772637b769998d90a718/colcon-notification-0.2.8.tar.gz)
-sha256sums=('3467248415f6acc8f434b3b36b875be3efa76e1166b95852881d9768e6f41c06')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+sha256sums=('6aae1ffe73ae956bcb36e330822cd230a2a88c9181b3170aafd1a446638e69b3')
package() {
- cd ${srcdir}/colcon-notification-${pkgver}
+ cd ${srcdir}/${_name}-${pkgver}
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 || echo "Not A Problem"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"