summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTong Chunli2018-11-02 22:08:41 +0800
committerTong Chunli2018-11-02 22:08:41 +0800
commit1a22a8ad1026585a364356f693b4c63955fd6cfc (patch)
tree626f72c70b70e9666a90d3ea94723c14258af618
downloadaur-1a22a8ad1026585a364356f693b4c63955fd6cfc.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eef9885b806
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-colcon-package-selection
+ pkgdesc = An extension for colcon-core to select a subset of packages for processing.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://pypi.org/project/colcon-package-selection
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-colcon-core
+ source = https://files.pythonhosted.org/packages/8f/56/a44e9c778905c2ed98101e8366460f9a4b5c13bad3aa0157627fe385dcc5/colcon-package-selection-0.2.1.tar.gz
+ sha256sums = 04fc346341d599321cf4efd17da6730888142482e6ec721d6fc30a04d3750125
+
+pkgname = python-colcon-package-selection
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eaec5b45d5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+pkgname=python-colcon-package-selection
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="An extension for colcon-core to select a subset of packages for processing."
+arch=(any)
+url="https://pypi.org/project/colcon-package-selection"
+license=('Apache')
+depends=('python-colcon-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/8f/56/a44e9c778905c2ed98101e8366460f9a4b5c13bad3aa0157627fe385dcc5/colcon-package-selection-$pkgver.tar.gz")
+sha256sums=('04fc346341d599321cf4efd17da6730888142482e6ec721d6fc30a04d3750125')
+
+
+package() {
+ cd ${srcdir}/colcon-package-selection-${pkgver}
+
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+}