summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2020-10-26 14:44:21 +0700
committerAchmad Fathoni2020-10-26 14:44:21 +0700
commit12446f3455c38a11fa0737b7465c740ce72e313f (patch)
tree553afa7bcc8e8745a1e92343f89dc5094e780eae
parentb054cf176113308d45dc34462cab56ed220de074 (diff)
downloadaur-12446f3455c38a11fa0737b7465c740ce72e313f.tar.gz
0.3.8
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4745686a4c47..6fe273096297 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-colcon-test-result
pkgdesc = An extension for colcon-core to provide information about the test results.
- pkgver = 0.3.3
+ pkgver = 0.3.8
pkgrel = 1
url = https://pypi.org/project/colcon-test-result
arch = any
license = Apache
makedepends = python-setuptools
depends = python-colcon-core
- source = https://files.pythonhosted.org/packages/03/c2/0c98c7bb1ebc3685fe02e62320955803e0bbbd3f80ea709eb0e4af6910ee/colcon-test-result-0.3.3.tar.gz
- sha256sums = 78f7d761418d2aa44b111b425db8d06294a2e3915d4f360f72336bb8966614a3
+ source = https://files.pythonhosted.org/packages/source/c/colcon-test-result/colcon-test-result-0.3.8.tar.gz
+ sha256sums = aa5225716a5bdd9f1df721e7a04f1e02150def8c86dd070793cb62e747c36ed3
pkgname = python-colcon-test-result
diff --git a/PKGBUILD b/PKGBUILD
index 520781f05b86..c4aaf9a87d21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-test-result
-pkgver=0.3.3
+_name=${pkgname:7}
+pkgver=0.3.8
pkgrel=1
pkgdesc="An extension for colcon-core to provide information about the test results."
arch=(any)
@@ -8,12 +10,12 @@ url="https://pypi.org/project/colcon-test-result"
license=('Apache')
depends=('python-colcon-core')
makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/03/c2/0c98c7bb1ebc3685fe02e62320955803e0bbbd3f80ea709eb0e4af6910ee/colcon-test-result-0.3.3.tar.gz)
-sha256sums=('78f7d761418d2aa44b111b425db8d06294a2e3915d4f360f72336bb8966614a3')
+source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
+sha256sums=('aa5225716a5bdd9f1df721e7a04f1e02150def8c86dd070793cb62e747c36ed3')
package() {
- cd ${srcdir}/colcon-test-result-${pkgver}
+ cd ${srcdir}/${_name}-${pkgver}
python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"