summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-06-17 10:14:05 +0300
committerCaleb Maclennan2022-06-17 10:14:05 +0300
commitc304d0346b99df83a61c219cb54ebab4dd7dbffd (patch)
treef03073fb7eabf8c8a6ebb4c98f65dbfedbeb8e69
downloadaur-c304d0346b99df83a61c219cb54ebab4dd7dbffd.tar.gz
Initial upload: python-collidoscope 0.4.1-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f0ce93c3baa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-collidoscope
+ pkgdesc = brute force detection of glyph collisions
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/simoncozens/collidoscope
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ depends = python-beziers
+ depends = python-glyphtools
+ depends = python-fonttools
+ depends = python-uharfbuzz
+ source = https://files.pythonhosted.org/packages/source/c/collidoscope/collidoscope-0.4.1.tar.gz
+ sha256sums = b7796d5d8981e04a2a652620d2063ef797d8fb3040c5383e574ae42f75537d1f
+
+pkgname = python-collidoscope
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f1e5eb68cfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=python-collidoscope
+_pyname=${pkgname#python-}
+pkgver=0.4.1
+pkgrel=1
+pkgdesc='brute force detection of glyph collisions'
+arch=(any)
+url="https://github.com/simoncozens/$_pyname"
+license=(MIT)
+_pydeps=(beziers
+ glyphtools
+ fonttools
+ uharfbuzz)
+depends=(python
+ "${_pydeps[@]/#/python-}")
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
+_archive="$_pyname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
+sha256sums=('b7796d5d8981e04a2a652620d2063ef797d8fb3040c5383e574ae42f75537d1f')
+
+build() {
+ cd "$_archive"
+ python -m build -wn
+}
+
+package() {
+ cd "$_archive"
+ python -m installer -d "$pkgdir" dist/*.whl
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+}