summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArne Beer2015-12-11 15:43:08 +0100
committerArne Beer2015-12-11 15:43:08 +0100
commite06e3185029a517b0a8464e001a608353405257a (patch)
tree70156aa1a4fc45daaaf493321bb1213ea9b1d871
downloadaur-e06e3185029a517b0a8464e001a608353405257a.tar.gz
Version 1.2.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e5d4e432153
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 14:42:57 UTC 2015
+pkgbase = python-colorclass-git
+ pkgdesc = Generate simple tables in terminals from a nested list of strings.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/Robpol86/colorclass
+ arch = any
+ license = MIT
+ makedepends = git python-setuptools
+ provides = python-colorclass
+ source = git+https://github.com/Robpol86/colorclass.git
+ sha256sums = SKIP
+
+pkgname = python-colorclass-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..669432aead37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+terminaltables/
+*.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97b89e39be89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Arne Beer <arne@twobeer.de>
+
+_gitname=colorclass
+pkgname=python-colorclass-git
+pkgver=1.2.0
+pkgrel=1
+arch=('any')
+pkgdesc='Generate simple tables in terminals from a nested list of strings.'
+license=('MIT')
+makedepends=('git python-setuptools')
+provides=('python-colorclass')
+url='https://github.com/Robpol86/colorclass'
+source=("git+https://github.com/Robpol86/colorclass.git")
+sha256sums=('SKIP')
+
+package() {
+ cd "${_gitname}"
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ # Install
+ python setup.py install --optimize=1 --root="${pkgdir}"
+
+ # Install License
+ # MIT/X11 license
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}