summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Schubert2024-02-28 19:09:37 +0100
committerMichael Schubert2024-02-28 19:09:37 +0100
commit7a9645178a1e245e0f521e74ae980fc02c54e543 (patch)
treea4c37f098820e5d508bd00af643fb04c63030660
parentd5aaa4467a2b1efe6724c703815351a9d202c9da (diff)
downloadaur-python-colormath.tar.gz
minor fixes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f33cb63a6434..aca1756f845b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,9 @@ pkgbase = python-colormath
arch = any
license = GPL3
makedepends = python-setuptools
- depends = python
depends = python-networkx
depends = python-numpy
- provides = python-colormath
- conflicts = python-colormath
- source = https://github.com/gtaylor/python-colormath/archive/3.0.0.tar.gz
- md5sums = 7a6fe120a4a688fb87b23f9930508471
+ source = colormath-3.0.0.tar.gz::https://github.com/gtaylor/python-colormath/archive/3.0.0.tar.gz
+ sha256sums = fffc8e0fc35055d45fb7e2e4bd87d42f9ef80b927bc66f8e812c1fc250996e7b
pkgname = python-colormath
-
diff --git a/PKGBUILD b/PKGBUILD
index e157d1583f19..ebb025de99f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Jeff M Hubbard <jeffmhubbard@gmail.com>
+# Maintainer: Michael Schubert <mschu.dev at gmail> github.com/mschubert/PKGBUILDs
+# Contributor: Jeff M Hubbard <jeffmhubbard@gmail.com>
# Contributor: Philippe Proulx <eeppeliteloop@gmail.com>
pkgname=python-colormath
pkgver=3.0.0
@@ -7,12 +8,10 @@ pkgdesc="Python module that abstracts common color math operations"
arch=('any')
url="https://github.com/gtaylor/python-colormath"
license=('GPL3')
-depends=('python' 'python-networkx' 'python-numpy')
-makedepends=('python-setuptools')
-provides=('python-colormath')
-conflicts=('python-colormath')
-source=('https://github.com/gtaylor/python-colormath/archive/3.0.0.tar.gz')
-md5sums=('7a6fe120a4a688fb87b23f9930508471')
+depends=(python-networkx python-numpy)
+makedepends=(python-setuptools)
+source=(colormath-$pkgver.tar.gz::https://github.com/gtaylor/python-colormath/archive/3.0.0.tar.gz)
+sha256sums=('fffc8e0fc35055d45fb7e2e4bd87d42f9ef80b927bc66f8e812c1fc250996e7b')
build() {
cd "$srcdir/$pkgname-$pkgver"