summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2016-02-04 22:36:33 -0800
committerAntony Lee2016-02-04 22:36:33 -0800
commit73ac5fc27277f35d05d52cecfc6371ddcb749eb0 (patch)
tree2c1313a36c275b4fe7366e5103726e2d3e482529
downloadaur-73ac5fc27277f35d05d52cecfc6371ddcb749eb0.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7daedbd8b92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 06:08:06 UTC 2016
+pkgbase = python-colorspacious
+ pkgdesc = A powerful, accurate, and easy-to-use Python library for doing colorspace conversions
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://colorspacious.readthedocs.org/en/latest/
+ arch = any
+ license = MIT
+ depends = python-numpy
+ md5sums = 437218f372a0a832a70299cc6397feb1
+ md5sums = 032f6276b1a63e4062c163daae656d61
+
+pkgname = python-colorspacious
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8ec21cf7adf5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014-2015 Colorspacious developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73c525df1ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+_pyname=colorspacious
+pkgname=python-$_pyname
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='A powerful, accurate, and easy-to-use Python library for doing colorspace conversions'
+url='http://colorspacious.readthedocs.org/en/latest/'
+depends=('python-numpy')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.zip"
+ 'LICENSE')
+md5sums=('437218f372a0a832a70299cc6397feb1'
+ '032f6276b1a63e4062c163daae656d61')
+
+build() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}