summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Brown2016-10-01 15:59:26 -0400
committerShane Brown2016-10-01 15:59:26 -0400
commitc9b81963722331105235e9b7bd06df150f559d4e (patch)
treecbe2a478870b221f793b515182da9cd80c1a0296
downloadaur-c9b81963722331105235e9b7bd06df150f559d4e.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88e2ddf5300a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-colorthief
+ pkgdesc = A Python module for grabbing the color palette from an image.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/fengsp/color-thief-py
+ arch = any
+ license = custom:3-clause BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pillow
+ provides = python-colorthief
+ source = https://github.com/fengsp/color-thief-py/archive/0.2.tar.gz
+ sha256sums = 7a7e00bb62ca4698b268b5aea0368d337443c4b10affd4e9f6b80b64a957eeff
+
+pkgname = python-colorthief
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebc330a3c230
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Shane "SajeOne" Brown <contact@shane-brown.ca>
+pkgname=python-colorthief
+pkgver=0.2
+pkgrel=1
+pkgdesc="A Python module for grabbing the color palette from an image."
+arch=('any')
+url="https://github.com/fengsp/color-thief-py"
+license=('custom:3-clause BSD')
+depends=('python' 'python-pillow')
+makedepends=('python-setuptools')
+provides=('python-colorthief')
+source=("https://github.com/fengsp/color-thief-py/archive/$pkgver.tar.gz")
+sha256sums=('7a7e00bb62ca4698b268b5aea0368d337443c4b10affd4e9f6b80b64a957eeff')
+_gitname=color-thief-py
+
+package() {
+ cd "$srcdir/$_gitname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ #LICENSE
+ install -D -m644 "$srcdir/$_gitname-$pkgver/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: