summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechcable2021-04-01 21:16:02 -0700
committerTechcable2021-04-01 21:16:53 -0700
commit2bd39bbd2344f63d3efa86d6018e729cbdf4398a (patch)
tree170e5f84667dae87e921595fec0824dbb1ad78d5
downloadaur-2bd39bbd2344f63d3efa86d6018e729cbdf4398a.tar.gz
Initial commit: Version 0.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a22636add2fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-columnize
+ pkgver = 0.3.10
+ pkgrel = 1
+ url = https://github.com/rocky/pycolumnize
+ arch = any
+ license = MIT
+ checkdepends = python-mock
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ makedepends = python-setuptools
+ source = columnize-0.3.0.tar.gz::https://github.com/rocky/pycolumnize/archive/refs/tags/0.3.10.tar.gz
+ sha256sums = c7947a57a126b6e5b4b585a19945909c3e64213979113948968304ebcf23daa4
+
+pkgname = python-columnize
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5318afef4dd7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Tars
+columnize*.tar.gz
+*.pkg.tar.zst
+
+# makepkg
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4789d3c3d0fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Techcable <Techcable at techcable dot net>
+pkgname=python-columnize
+pkgver=0.3.10
+pkgrel=1
+epoch=
+pkgdesc="Python module to align a simple (not nested) list in columns."
+arch=("any")
+url="https://github.com/rocky/pycolumnize"
+license=('MIT')
+groups=()
+depends=()
+makedepends=("python-setuptools")
+checkdepends=("python-mock" "python-pytest" "python-pytest-cov")
+backup=() # Anything we need to backup?
+options=()
+install=
+changelog=
+source=("columnize-0.3.0.tar.gz::https://github.com/rocky/pycolumnize/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=("c7947a57a126b6e5b4b585a19945909c3e64213979113948968304ebcf23daa4")
+
+prepare() {
+ true; # Nothing to do I guess
+}
+
+build() {
+ cd "pycolumnize-$pkgver"
+ python3 ./setup.py build;
+}
+
+check() {
+ cd "pycolumnize-$pkgver"
+ make check;
+}
+
+package() {
+ cd "pycolumnize-$pkgver"
+ python setup.py install --root="$pkgdir/" --prefix="/usr"
+}