summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-17 21:19:52 -0400
committerGuillaume Horel2019-08-17 21:19:52 -0400
commitd92a0c89169de649d48ca710ab65ec7a2fc338c3 (patch)
treefa50d9189923fc59594a749d3cda5344ea0ebe3a
downloadaur-d92a0c89169de649d48ca710ab65ec7a2fc338c3.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f6a6b5d351b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-compreffor
+ pkgdesc = A CFF table suroutinizer for FontTools.
+ pkgver = 0.4.6.post1
+ pkgrel = 1
+ url = https://github.com/googlefonts/compreffor
+ arch = x86_64
+ license = Apache
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-fonttools
+ source = https://pypi.org/packages/source/c/compreffor/compreffor-0.4.6.post1.zip
+ sha256sums = 6e3027d0247f3c52dbda7bce1143c9e2c7aa4a496c8e0d76d7dc424bfc9a6749
+
+pkgname = python-compreffor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..090f893fd6be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-compreffor')
+_pkgname='compreffor'
+pkgver='0.4.6.post1'
+pkgrel=1
+pkgdesc="A CFF table suroutinizer for FontTools."
+url="https://github.com/googlefonts/compreffor"
+checkdepends=()
+depends=('python' 'python-fonttools')
+makedepends=('cython' 'python-setuptools')
+optdepends=()
+license=('Apache')
+arch=('x86_64')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('6e3027d0247f3c52dbda7bce1143c9e2c7aa4a496c8e0d76d7dc424bfc9a6749')
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}