summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-04-25 18:59:37 +0200
committerMarco Rubin2022-04-25 18:59:37 +0200
commite723c0bbfb780b03687d50f7cf1623cea7cf0775 (patch)
treeb8fed3a88fd18dcd591c7c7095c5db87acc96e8c
downloadaur-e723c0bbfb780b03687d50f7cf1623cea7cf0775.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD25
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca85f3cf00ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-concur
+ pkgdesc = Beautiful side-by-side diffs
+ pkgver = 0.10.0
+ pkgrel = 1
+ url = https://github.com/darrenburns/dunk
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-concur-imgui
+ source = https://files.pythonhosted.org/packages/source/c/concur/concur-0.10.0.tar.gz
+ sha256sums = c1773837e6e5fb5dcbe533d12954e3a18bdbf3881f2cc1038a86fb12ee517d72
+
+pkgname = python-concur
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..10537db07670
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2019 Pavel Potoček
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34bae7b8100d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+
+_name=concur
+pkgname=python-$_name
+pkgver=0.10.0
+pkgrel=1
+pkgdesc='Beautiful side-by-side diffs'
+arch=(any)
+url='https://github.com/darrenburns/dunk'
+license=('MIT')
+depends=(python python-concur-imgui)
+makedepends=(python-build python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('c1773837e6e5fb5dcbe533d12954e3a18bdbf3881f2cc1038a86fb12ee517d72')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 ../../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}